Clicking on targeted links doesn't work.

VERIFIED DUPLICATE of bug 17468

Status

()

Core
XUL
P2
normal
VERIFIED DUPLICATE of bug 17468
19 years ago
19 years ago

People

(Reporter: Mathieu Fenniak, Assigned: Dan M)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Using the latest daily build, and every daily build over the past week or so at
least, clicking on some of the links on the given url
(http://www.digitalroutes.co.uk/office/clients.html) doesn't work properly. In
mozilla proper, clicking seems to do nothing at all, except that when shutting
down the browser the desired window is seen for a split second. Using the
gtk_browser, the window opens properly and loads the correct client web site.

Comment 1

19 years ago
Hm.  Nothing here to suggest it's the JavaScript engine.  Other than that, I'm
stumped.  Firing it to Browser-General, in case that'll put it on Bugathon
radar.
Assignee: mccabe → leger
Component: Javascript Engine → Browser-General
(Reporter)

Comment 2

19 years ago
I assumed javascript problem because of the link opening new window thing. My
mistake, then, sorry. :)
The links in this page are of the form <a href="..." target="new">...</a>.

Updated

19 years ago
Assignee: leger → mccabe
Component: Browser-General → Javascript Engine

Comment 4

19 years ago
Moving to proper component.

Updated

19 years ago
Assignee: mccabe → leger
Component: Javascript Engine → Browser-General

Comment 5

19 years ago
Jan -

The JavaScript engine is not the proper component.  This seems to be a problem
in the UI, or in some other aspect of the browser.

The JavaScript engine component isn't links, or behaviors of the DOM (such as
document.write) that happen to be exposed to JavaScripts, or HTML parsing or
networking.  Please take care when assigning bugs to the JavaScript component,
because 90% of the bugs assigned to this component aren't problems with
JavaScript.

Comment 6

19 years ago
cc'ing Chris because he mentioned 'issues' with targeted links not too long
ago.  Chris, is the the same trouble you saw, maybe even a dup?

Updated

19 years ago
Assignee: leger → trudelle
Component: Browser-General → XP Toolkit/Widgets
QA Contact: rginda → claudius

Comment 7

19 years ago
Per don's comments in a mail:
"could be some frame targeting problem since you can't
even openthe "clients.html" frame in its own window.  Since these
links aresupposed to bring up new windows, I think this might be a
job for Dan Matejka on the XPToolkit team.'

Will try XP Toolkit, trudelle - what do  you think?

Updated

19 years ago
Assignee: trudelle → danm
Priority: P3 → P2
Summary: Clicking on links doesn't work. → Clicking on targeted links doesn't work.
Target Milestone: M13

Comment 8

19 years ago
sounds like a regression.  assigning to danm as p2 for m13
Is this the same as bug 17468 (which has a fix attached to it)?

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 10

19 years ago
*** This bug has been marked as a duplicate of 17468 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
This bug is verified to be a dupe of bug 17648. jst@citec.fi verified that the
fix
to bug 17648 also fixed this bug.
You need to log in before you can comment on or make changes to this bug.