Resize handles of a image or table aren't automatically repositioned after the user stops resizing the window

REOPENED
Assigned to

Status

()

Core
Editor
REOPENED
16 years ago
12 years ago

People

(Reporter: Chris Petersen, Assigned: glazou)

Tracking

({topembed+})

Trunk
PowerPC
Mac OS X
topembed+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: editorbase+)

(Reporter)

Description

16 years ago
Build: 2003-02-25-03
Platform: OSX 10.2
Expected Results: Handles of the image or table should appear at the correctly
position after resizing the window.
What I got: The handles of the image and table appear at the wrong position
until after the user has mouse up (even though the window is no longer being
resized).

Steps to reproduce:

Insert a table

1) Specify a table with 50% width
2) Select the table to display it's handle's.
3) Now manually resize the window and watch the table reposition itself.
4) Stop resizing the window but continue to hold down the mouse.
5) Notice the handle position are not corrected until you mouse up.


Insert a image

1) Type some text
2) Insert a small image so that it appears inline with the text
3) Manually resize the window and watch the image reposition itself.
4) Stop resizing the window but continue to hold down the mouse.
5) Notice the handle position are not corrected until you mouse up.

Comment 1

16 years ago
-->glazman
Assignee: composer → glazman
Component: Editor: Composer → Editor: Core
(Reporter)

Comment 2

16 years ago
Revised summary
Component: Editor: Core → Editor: Composer
Summary: Resize handles of a image or table aren't automatically repositioned after window's size has changed → Resize handles of a image or table aren't automatically repositioned after the user stops resizing the window

Updated

16 years ago
Component: Editor: Composer → Editor: Core
Keywords: nsbeta1, topembed
Whiteboard: editorbase
(Reporter)

Comment 3

16 years ago
I can't reproduced the issue under the Win32 or Linux trunk builds. When I stop
resizing the window (using either of these builds), the resize handles are
correctly repositioned on the table or image.
(Assignee)

Comment 4

16 years ago
That bug was totally independant of my code.

Clearly a recent checkin changed the way "resize" events are fired. Before
that checkin, the event was fired only after completeness of window resizing,
ie when mouse was up again. It's now dynamic.

==> RESO/FIXED by other recent checkin.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 5

16 years ago
reopen bug; I don't understand why MacOSX is different behavior from other OS
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

16 years ago
Keywords: topembed → topembed+
QA Contact: sujay → beppe
EDITORBASE+
Whiteboard: editorbase → editorbase+
(Assignee)

Comment 7

16 years ago
fix for this bug is included in patch attached to bug 195412

Updated

16 years ago
Depends on: 195412
(Assignee)

Comment 8

16 years ago
fixed by recent check-in of fix for bug 195412
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

16 years ago
This is still a issue on the Macho (2003-03-26-15) trunk build. So reopening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

16 years ago
In order for the image's or table's handles to appear at the proper location, I
must mouseup even though I have stopped resizing the window. On the window
build, I can continue to mouse down and the handles will automatically appear at
image's/table's new location.

Comment 11

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
QA Contact: rubydoo123 → editor
You need to log in before you can comment on or make changes to this bug.