All users were logged out of Bugzilla on October 13th, 2018

File name does not get populated automatically on download

VERIFIED DUPLICATE of bug 16043

Status

P2
normal
VERIFIED DUPLICATE of bug 16043
19 years ago
14 years ago

People

(Reporter: biswapesh, Assigned: law)

Tracking

({platform-parity})

Trunk
x86
Linux
platform-parity

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build: M11 (1999111520) System: WinNT SP5 PII 64 MB RAM The 'Save File' dialog
does not pass the file name to the Windows 'Save File' dialog. So, while
downloading, one has to enter the file name manually. Also, if you right-click
on a link, choose 'Save Link As', proceed upto the Windows 'Save As' dialog and
then cancel, the Mozilla 'Save As' dialog does not disappear, so you have to
select 'Cancel' there as well.

Updated

19 years ago
Assignee: leger → don
Component: Browser-General → XPApps
QA Contact: leger → don
Summary: File name does not get populated automatically while downloading. → [4.xP] No filenames generated for index files on d/l

Comment 1

19 years ago
With the current M12 build, any *existing* filename is passed to the "Save File"
dialog that appears after "Save Link as..." is chosen on the context menu.
On the other hand, if there is no filename portion to the url (example:
http://www.mozilla.org/), no filename is generated (e.g., www_mozilla_org.html)
as happens with Communicator.

The same applies to "File>Save Page as" if the current page is an index page.

Regarding the second issue, with this build the "Saving File" dialog does
not appear until after the "Save File" dialog is [Ok]'d.

Tested with: 1999-11-29-08-M12 nightly binary on Windows NT 4.0sp3

Marking [4.xP].
Changing Summary from "File name does not get populated automatically while
downloading" to "[4.xP] No filenames generated for index files on d/l"
Changing Component from "Browser-General" to "XPApps".

Comment 2

19 years ago
Another problem is the URL bar changes when you click on a link to download it
and then cancel it.
Test Case: Go to http://www.xitami.com/download.htm . Click on swin24d6.zip.
The Mozilla 'Unknown File Type' dialog appears. Click 'Cancel'
Result: The URL bar changes to the link to the zip file. Subsequently, if you
choose File->Save Page As; the file name passed to the 'Save File' dialog
is 'swin24d6.zip'
Expected Result: The URL bar should remain unchanged. The 'Save page As' option
should pass null parameter to 'Save File' dialog.

Other Info: This problem does not occur if you right-click on the link and
follow the rest of the procedure.

Updated

19 years ago
Assignee: don → law

Comment 3

19 years ago
save as, law.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M15

Comment 4

19 years ago
Somebody convince me we need to fix this for beta 1.

Comment 5

19 years ago
Observed on Linux build 2000.01.07.08:

1. Go to http://mozilla.org
2. Click on one of the ftp links for nightly builds in the lower right and
choose save as; or right click and select save link as
Save file dialog appears, without filename, even though the filename is
part of the URL

The same happens with http links, eg when trying to save the link to
"Newsgroups" on the front page (http://www.moziall.org/community.html)

Does this happen on other platforms as well?  Should I file a separate bug?
Change the summary (It's not just index pages that have the problem)?

In any case, this is pretty annoying and should be fixed for beta.

Updated

19 years ago
QA Contact: don → sairuh

Comment 6

19 years ago
more sairuh

Comment 7

19 years ago
The filename is not getting populated in the X "File Save" dialog on Linux, but
it is on NT.  Will open a new bug for the no filename generated for index pages
issue, for clarity. Restoring original Summary, adding [pp] code.

Tested with: 2000-01-22-09-M14 nightly binary on Linux custom Slackware 4.0,
fvwm2.
Keywords: pp
OS: Windows NT → Linux
Summary: [4.xP] No filenames generated for index files on d/l → File name does not get populated automatically on download

Comment 8

19 years ago
Marking as a DUP of bug 16043, "Saving downloads does not suggest a file name",
currently marked FIXED, although this means REOPENing that bug.

The new bug for "[4.xP] No filenames generated for index files on d/l" is 
bug 24817.

Comment 9

19 years ago

*** This bug has been marked as a duplicate of 16043 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.