Closed Bug 195238 Opened 17 years ago Closed 17 years ago

Junk toolbar button text should say "Not Junk" if junk messages are selected

Categories

(SeaMonkey :: MailNews: Message Display, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.4alpha

People

(Reporter: sspitzer, Assigned: sspitzer)

References

Details

Attachments

(1 file, 1 obsolete file)

Junk toolbar button text should say "Not Junk" if junk messages are selected.

for how to determine if the selected messages are junk, use

mailWindowOverlay.js(538):function SelectedMessagesAreJunk()
*** Bug 194955 has been marked as a duplicate of this bug. ***
note to jan, we want to make sure that after the user hits the "This Is Not
Junk" button in the message envelope (see
http://www.mozilla.org/mailnews/specs/spam/images/Spam5.gif), that the toolbar
text updates.
Status: NEW → ASSIGNED
taking back, jan is busy on the bookmarks branch landing, and I have cycles for
this.
Assignee: varga → sspitzer
Status: ASSIGNED → NEW
Target Milestone: --- → mozilla1.4alpha
Attached patch fix (obsolete) — Splinter Review
Attached patch updated fixSplinter Review
includes fixes for bug #168496 and bug #198877 and disables the junk mail UI
for news (since it isn't supported yet)
Attachment #118234 - Attachment is obsolete: true
fixed.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Using trunk build 20030325 on winxp, macosx and linux is fixed. Verified   and
so are the bugs mentioned above. 
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.