no refresh unless resize of windows after opening multiple tabs for image viewing

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: Antoni Ten, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2.1) Gecko/20021130

after entering an image gallery, and opening 50+ images in diferent tabs, with
the open in background option, Mozilla fails to update the windows. Only 2 fixes
in order to see the content: either resize the window and/or move back and forth
in the page. Parts of the page that where not visible refresh without problems.
This also affects to the interface, notable the tab bar, the navigation bar, etc etc

Reproducible: Always

Steps to Reproduce:
1. go to an image gallery
2.load the images in the background. Load 50+ (better is 100+) images in the
background


Actual Results:  
all the mozilla components fail to update the screen correctly, thus neding to
force a retraw in order to be able to actualy see the correct information on
screen. Ways tested to force the redraw: using some of the pull down menus to
cover the screen (like the bookmarks pull down) so what is imediately under it
gets refreshed, resizing the window to a smaller size, movin the page up and
down, to show parts of it that where not visible before. This is however
temporary, since should you ned to refresh again the screen, for example after
swapping tabs, you sould for the update again. Mozilla neds to be completely
restarted for things to go back to normal

Expected Results:  
normal updates on the screen

Comment 1

15 years ago
I've seen this as well, and not with creation in background.  If I open 
somewhere like 15+ tabs that each have 20-30 thumbnails on them I get the same 
behaviour.  

Running WinXP and it not only messes up the redraws on Mozilla, but also on 
other running programs.  It inhibits their redrawing in the same manner.
Dup of the usual "GDI sucks" bug...
Whiteboard: DUPEME

Comment 3

13 years ago
The GDI problem has been fixed for a while I think..

Reporter, do you still see this problem with the latest nightly (or even 1.7.3)?
If not, the bug has probably been fixed and can be closed. Thanks.
(Reporter)

Comment 4

13 years ago
Seems fixed in the latest release
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 5

13 years ago
No bug / patch specified as the fix.

-> WORKSFORME
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.