completely ignored max-width CSS property in table

RESOLVED DUPLICATE of bug 143023

Status

()

Core
Layout: Tables
--
trivial
RESOLVED DUPLICATE of bug 143023
15 years ago
15 years ago

People

(Reporter: Stefan Urbat, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; X11)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1; MultiZilla v1.1.31) Gecko/20021130

Opposed to margin-right the max-width property seems to be completely ignored in
the given HTML test page. The table grows ever more, when expanding the window
to the right. Though the width is given in the (same) font unit em, it should be
respected like it is for the text paragraphs above and below.

Reproducible: Always

Steps to Reproduce:
1. Load above URL
2. Scroll down to the bordered table
3. resize the window in width to small, medium and especially large dimensions:
then you will discover the mentioned ignorance.
Actual Results:  
The table grows as far to the right, as the window is drawn bigger, only
respecting the margin-right property, but completely ignorant of the max-width
property

Expected Results:  
Stop to expand the table after the max-width limit has been reached, even if the
window is drawn even more wide then. The pictures show Opera 7 screenshots and
that its Presto engine opposed to the Gecko engine limits the table like the
text paragraphs to the given (in comparison slightly bigger) em value.

Nothing special. Additionally it was tested on Mac OS X with Mozilla 1.3 beta
without any mozdev.org addons, and shows exactly the same behaviour as on 1.2.1
on GNU/Linux, it holds also true on W2k and Mozilla 1.2.

*** This bug has been marked as a duplicate of 143023 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.