Mozilla implementation of GRE creates multiple instance confusion

RESOLVED WONTFIX

Status

Core Graveyard
Installer: GRE
P1
critical
RESOLVED WONTFIX
15 years ago
6 years ago

People

(Reporter: Charles Rosendahl, Assigned: Sean Su)

Tracking

({topembed+})

Trunk
x86
Windows 2000
topembed+

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
Using the latest nightly builds, or any builds using a private GRE installation,
if two or more installations of mozilla are installed into different
directories, all uninstallers will delete that last mozilla installation
installed and render the remaining uninstallers broken beyond that point.

1.  Install two instances of mozilla into two distinct directories.
2.  Check the registry settings of the GRE - notice everything points to the
last installation only, with the exception of the pathtoexe keys in the applist key.
3.  cd to the uninstall directory of the first mozilla installation and run the
uninstaller.
4.  Notice the second installation was deleted instead of the first.
(Reporter)

Comment 1

15 years ago
According to the spec, this might be because you are calling the uninstaller
without the /app_path param?

(specs need updating), but

calling the uninstaller with only the /app param will delete the applist entry
and potentially the GRE.  adding the /app_path param should remove the pathtoexe
entry , then potentially the applist entry and GRE installation.

I kind of think it is a bug to be able to specify the app param only and wipe
out the applist entry.  

At the least, the uninstaller should check that there are not valid multiple
instances installed under the applist entry before removing it.  

if there are multiple valid entries, then the uninstaller should not perform the
uninstall.  

If there is only one entry, then the uninstaller may proceed.
(Reporter)

Comment 2

15 years ago
*** Bug 197481 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
Should be fixed before any product ships GRE.
Severity: major → critical
Priority: -- → P1
(Reporter)

Updated

15 years ago
Whiteboard: nsbeta1 topembed
(Reporter)

Updated

15 years ago
Keywords: nsbeta1, topembed
Whiteboard: nsbeta1 topembed

Comment 4

15 years ago
Discussed in edt bug triage.  Plussing.
Keywords: topembed → topembed+

Comment 5

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Product: Core → Core Graveyard
The GRE installer is long dead
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.