Problems with mouse events, specifically the target (srcElement) of those events. (mozilla 1.3)

RESOLVED DUPLICATE of bug 102339

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 102339
15 years ago
14 years ago

People

(Reporter: Colin Lear, Assigned: saari (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.0; UNIX) Opera 6.11  [en]
Build Identifier: Mozilla 1.3a & Mozilla 1.3b

I have been making a drag and drop application. I have it working successfully in Mozilla 1.2.1, Netscape 7.0, Internet Explorer 6.

There is a problem in Mozilla 1.3 where the target of the mouseup/mouseover/mouseout events appear to be wrong.

Reproducible: Always

Steps to Reproduce:
1. Load the example URL
2.Click and hold the mouse button over one of the table cells with a letter in them.
3.Drag the cell up or down (there should appear a popup table that follows the mouse pos.
4. Release the mouse button.

Actual Results:  
The event reported in the textarea shows that the mouseover event gets called after the mouseout with the innerhtml of the target being the element it left not the one it entered. In Addition the innerHTML of the target of the mouseup event is the same as that of the mousedown

Expected Results:  
The first mouseover event should have had different target than the mousedown.
the mouseup event should have a target set to the element which was under the pointer when the button was released

It is difficult using this example to determine if this happens with all events or just with events added from javascript using this syntax.

document.onevent=handler;

There seems to be more than one problem occuring. Mostly it appears to be a problem with the target of an event not being reported correctly (from my understanding) but other problems are the registering of the mouseover/mouseout events not working correctly.

I have not tested this problem on windows or mac. (only linux)
(Reporter)

Updated

15 years ago
Summary: Problems with mouse events, specifically the target (srcElement) of those events. → Problems with mouse events, specifically the target (srcElement) of those events. (mozilla 1.3)
(Reporter)

Comment 1

15 years ago
This still occurs in the releave version of 1.3 for linux (redhat8 rpm)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313
(Reporter)

Comment 2

15 years ago
This bug is a duplicate of Bug 102339.

I disagree with the assessment of that bug. This behavior is inconsistent. No 
workaround is mentioned.

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 102339 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.