Closed Bug 19539 Opened 23 years ago Closed 23 years ago

32-bit PNGs with 8-bit alpha are treated as 1-bit alpha

Categories

(Core :: Graphics: ImageLib, enhancement, P3)

x86
All
enhancement

Tracking

()

VERIFIED DUPLICATE of bug 3013

People

(Reporter: the_olo, Assigned: newt)

References

()

Details

Mozilla treats 32-bit PNG images (8-bit alpha channel) as if they had
1-bit alpha channel (binary transparency, as in GIF format).
That's more like a missing feature than a bug, but webmasters have been waiting
for ages to get full 8-bit alpha channel support in WWW browsers (binary
transparency model gives jerky pixels on the decal image's edges)
See the URL above, http://sudety/pnghtml/index.html and
http://www.cdrom.com/pub/png/ for more info on PNG and its various transparency
modes.
Assignee: pnunn → newt
Reassigning to Greg, presumably to resolve as dupe.
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
Note that the URL is invalid; you might wish to append a fully qualified one to
bug 3013.

Greg

*** This bug has been marked as a duplicate of 3013 ***
Status: RESOLVED → VERIFIED
Verifying as duplicate. Thanks, Greg.

Unsure what the URL the_olo meant to submit, so I'll defer to him. (simply adding
www & com doesn't make it work.)
You need to log in before you can comment on or make changes to this bug.