[DOGFOOD] [CRASH] Changing order of bookmarks crashes browser.

VERIFIED FIXED in M13

Status

SeaMonkey
General
P3
critical
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: kinmoz, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
The browser crashes when I try to change the order of bookmarks in my list.

To reproduce:

1. Start the browser.
2. Select Bookmarks->Manage Bookmarks from the menus
3. Click and hold the mouse button on a bookmark in the list and drag it to
another place in the list and let go of the button.

You should crash with the following stack trace:


nsEventStateManager::UpdateCursor(nsIPresContext & {...}, nsPoint & {...},
nsIFrame * 0x040814d0, nsEventStatus & nsEventStatus_eIgnore) line 923 + 21
bytes
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x0406ded0,
nsIPresContext & {...}, nsGUIEvent * 0x0012fbd0, nsIFrame * 0x040814d0,
nsEventStatus & nsEventStatus_eIgnore, nsIView * 0x04026380) line 178
PresShell::HandleEvent(PresShell * const 0x040243f4, nsIView * 0x04026380,
nsGUIEvent * 0x0012fbd0, nsEventStatus & nsEventStatus_eIgnore) line 2432 + 43
bytes
nsView::HandleEvent(nsView * const 0x04026380, nsGUIEvent * 0x0012fbd0, unsigned
int 28, nsEventStatus & nsEventStatus_eIgnore, int & 0) line 840
nsViewManager::DispatchEvent(nsViewManager * const 0x040250c0, nsGUIEvent *
0x0012fbd0, nsEventStatus & nsEventStatus_eIgnore) line 1724
HandleEvent(nsGUIEvent * 0x0012fbd0) line 69
nsWindow::DispatchEvent(nsWindow * const 0x04026244, nsGUIEvent * 0x0012fbd0,
nsEventStatus & nsEventStatus_eIgnore) line 438 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fbd0) line 459
nsWindow::DispatchMouseEvent(unsigned int 300, nsPoint * 0x00000000) line 3493 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 300, nsPoint * 0x00000000) line
3711
nsWindow::ProcessMessage(unsigned int 512, unsigned int 1, long 6160435, long *
0x0012fdfc) line 2756 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00b10684, unsigned int 512, unsigned int 1, long
6160435) line 625 + 27 bytes
USER32! 77e71250()

Updated

19 years ago
QA Contact: leger → claudius

Comment 1

19 years ago
[qa assigning to claudius.]

Updated

19 years ago
Assignee: leger → rjc

Comment 2

19 years ago
reassigning to likely guilty parties. Guys, is this supposed to work now or should it
just not crash at this point? and what component should bugs like this be under?
(Assignee)

Updated

19 years ago
Summary: [CRASH] Changing order of bookmarks crashes browser. → [DOGFOOD] [CRASH] Changing order of bookmarks crashes browser.
(Assignee)

Comment 3

19 years ago
placing on dogfood radar.

Updated

19 years ago
Assignee: rjc → pinkerton

Comment 4

19 years ago
Giving Pink some bug luv...

Updated

19 years ago
Whiteboard: [PDT-]

Comment 5

19 years ago
Putting on the PDT- radar.  Must fix for beta, but not mandatory for dogfood.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

19 years ago
accepting.
(Assignee)

Updated

19 years ago
Target Milestone: M13
(Assignee)

Comment 7

19 years ago
m13, unless you want to take a look at this one, rjc?

Comment 8

19 years ago
Mike, try this patch (add the two "RemoveEventListener" lines to the DTOR) and
see if it fixes the crash for you (it does for me):


// Destructor
nsTreeRowGroupFrame::~nsTreeRowGroupFrame()
{
  nsCOMPtr<nsIContent> content;
  GetContent(getter_AddRefs(content));
  nsCOMPtr<nsIDOMEventReceiver> reciever(do_QueryInterface(content));

**  reciever->RemoveEventListener("dragover", mDragCapturer, PR_TRUE);
**  reciever->RemoveEventListener("dragexit", mDragCapturer, PR_TRUE);

  // NOTE: the Remove will delete the drag capturer
  reciever->RemoveEventListenerByIID((nsIDOMDragListener *)mDragCapturer,
nsIDOMDragListener::GetIID());

  NS_IF_RELEASE(mContentChain);
}
(Assignee)

Comment 9

19 years ago
this seemed to work. after talking with hyatt, he said just called
RemoveEventListenerByIID() should be enough, but obviously it isn't ;)

good catch rjc, i'll check this in when hyatt's tree regressions clear ;)
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

19 years ago
fixes checked in. thanks again rjc.

Comment 11

19 years ago
*** Bug 20525 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 12

18 years ago
VERIFIED Fixed with 2000011808 build
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.