Print Preview scroll bar displays incorrectly with 'print background' off in page setup

RESOLVED DUPLICATE of bug 191938

Status

()

--
trivial
RESOLVED DUPLICATE of bug 191938
16 years ago
16 years ago

People

(Reporter: sac+moz, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

In the print preview view, the scroll bar only displays properly if print
background is on. Otherwise, only the outline of it is visible. On some themes,
the end arrow buttons do not show.
I think the problem is that the background images for the scroll bars themselves
are not being drawn. Similar effect as #120616, scroll bars should not be linked
to the document style information.

Reproducible: Always

Steps to Reproduce:
1.open page setup, uncheck print background (default setting)
2.open print preview
3.scroll bars display as just outlines blank space inside them
4.open page setup again, turn on print backgrounds
5.scroll bars in preview look normal

Actual Results:  
scroll bar only shows outline with print background

Expected Results:  
scroll bar should look the same regardless of print background setting

Comment 1

16 years ago
This is/was bug 191938.
It is fixed in current nightlies (but not in the 1.3 branch, so 1.3 will still
have this bug). 

*** This bug has been marked as a duplicate of 191938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.