Closed Bug 195552 Opened 18 years ago Closed 18 years ago

The acronym and abbr tags treat line breaks in the HTML as significant if they occur within their respective title attributes.

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 67127

People

(Reporter: eric, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.3b) Gecko/20030212

If source HTML contains a line break within the title attribute of an acronym or
abbr tag, Mozilla treats it as significant and attempts to render it in the
pop-up  displayed for the acronym or abbr rather than just treating it as white
space.

For example, if the acronym SCUBA is written thusly:

<acronym title="Self-Contained Underwater Breathing Apparatus">SCUBA</acronym>

everything is fine, but if it is written like this:

<acronym title="Self-Contained Underwater Breathing
Apparatus">SCUBA</acronym>

then Mozilla does funny things.


Reproducible: Always

Steps to Reproduce:
1. try to view some HTML with an acronym or abbr with a title that crosses a
logical line.

Actual Results:  
On my system, I see a graphic character and a bunch of white space in the middle
of the acronym or abbr pop-up.

Expected Results:  
The line break should have just been treated as a single space and the pop-up
should have been displayed without graphics characters and extra space.

*** This bug has been marked as a duplicate of 67127 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.