when I write the command "mozilla" in the shell it says "Segmentation Fault".

RESOLVED INVALID

Status

Core Graveyard
Talkback Client
--
critical
RESOLVED INVALID
15 years ago
8 years ago

People

(Reporter: albert, Assigned: Shiva Thirumazhusai)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/4.79 [en] (X11; U; Linux 2.4.18-3 i686)
Build Identifier: ftp.mozilla.org

If i click on the mozilla icon it loads for a while but it doesn't come up. If I
try to open it from the shell it says "Segmentation Fault".

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
You say you couldn't reproduce? Did this happen only once, in other words?
Which directory at ftp.mozilla.org did you get the mozilla build from, and what
was the filename?
Have you had Mozilla installed before?
What happens if you start it as "mozilla -profilemanager"?

Comment 2

15 years ago
Is there anything suspicous in "strace mozilla"?
Do you recall if there were other Mozilla processes running when you got your
warning? No steps that you can recall as possible relevant leading to your issue?

Comment 3

15 years ago
Reporter mailed:

"I fixed it by installing mozilla into my home directory but the problem is
still there (except if i use the run-mozilla.sh file"

Comment 4

15 years ago
confirmed for me - i cannot run latest nightly :(

$ catchsegv mozilla
/home/ballpark/pkg/mozilla/run-mozilla.sh: line 454:  3256 Segmentation fault  
   "$prog" ${1+"$@"}
*** Segmentation fault
Register dump:

 EAX: 033b8000   EBX: 44c74528   ECX: 033b8000   EDX: 033b8000
 ESI: 033b8000   EDI: b46fc9ac   EBP: b46fb944   ESP: b46fb8d0

 EIP: 44c7251e   EFLAGS: 00010206

 CS: 0023   DS: 002b   ES: 002b   FS: 0000   GS: 0007   SS: 002b

 Trap: 0000000e   Error: 00000004   OldMask: 80000000
 ESP/signal: b46fb8d0   CR2: 033b8000

 FPUCW: ffff037f   FPUSW: ffff4023   TAG: ffffffff
 IPOFF: 44bdf1c9   CSSEL: 0023   DATAOFF: 080d7d40   DATASEL: 002b

 ST(0) 0000 0000000000000000   ST(1) 0000 0000000000000000
 ST(2) 0000 0000000000000000   ST(3) 0000 e000000000000000
 ST(4) 0000 8000000000000000   ST(5) 0000 b400000000000000
 ST(6) 0000 a8c0000000000000   ST(7) 0000 fffffffffffff800

Backtrace:
/home/ballpark/pkg/mozilla/components/libqfaservices.so(FindRange__11FCModuleMgrUlUl+0x26)[0x44c7251e]
/home/ballpark/pkg/mozilla/components/libqfaservices.so(GetNextModule__11FCModuleMgr+0xab)[0x44c7240f]
/home/ballpark/pkg/mozilla/components/libqfaservices.so(FindModule__11FCModuleMgrUl+0x3f)[0x44c724bb]
/home/ballpark/pkg/mozilla/components/libqfaservices.so[0x44c70e70]
/home/ballpark/pkg/mozilla/components/libqfaservices.so[0x44c70f48]
/home/ballpark/pkg/mozilla/components/libqfaservices.so(FCInitialize+0x1f)[0x44c713cb]
/home/ballpark/pkg/mozilla/components/libqfaservices.so(StartService__17nsQfaServicesImpl+0x1c)[0x44c708d4]
/home/ballpark/pkg/mozilla/components/libqfaservices.so(Observe__17nsQfaServicesImplP11nsISupportsPCcPCUs+0x1b)[0x44c709a3]
/home/ballpark/pkg/mozilla/components/libembedcomponents.so[0x45427585]
/home/ballpark/pkg/mozilla/mozilla-bin[0x80578a7]
/home/ballpark/pkg/mozilla/mozilla-bin(main+0x12d)[0x80584c5]
/lib/libc.so.6(__libc_start_main+0xa4)[0x44ffae54]
/home/ballpark/pkg/mozilla/mozilla-bin(__register_frame_info+0x4d)[0x8054a51]

Comment 5

15 years ago
Worksforme. Both Moz from February 28 and 2003030122.
Mandrake Linux 9.1 RC1. Installed as root into /usr/lib/mozilla.

I manually modified /usr/bin/mozilla to point to /usr/lib/mozilla instead of the
default values for MOZILLA_FIVE_HOME that are in there.

I think that this is fall-out from the fixes for bug 163524 and possibly 144331.
Nominating for dupe 

Comment 6

15 years ago
regarding comment 5 : No, you are wrong! please do not mark this a duplicate!

Notes: Removed ~/.mozilla to confirm same problem.

strace will be attached below in just a second.

Comment 7

15 years ago
see bug 195251.

Comment 8

15 years ago
Created attachment 116039 [details]
strace -f  of mozilla crash

Comment 9

15 years ago
ballpark: what build ID are you using?

Comment 10

15 years ago
Build 2003030122 on Linux 

Comment 11

15 years ago
Still Happenning with Mozilla 1.4a, Copyright (c) 2003 mozilla.org, build 2003030205

This really sucks, im going to have to go back to the 1.3b release, as i
currently have no browser as i didnt save the last working nightly :(

Comment 12

15 years ago
I see also "Segmentation fault" problem. I use my own CVS builds on RH80 with
Xft support activated.

  build 2003-02-28-00 works
  build 2003-03-02-08 crashes with Segmentation fault
  build 2003-03-03-04 crashes with Segmentation fault
Keywords: crash

Comment 13

15 years ago
Confirming on Linux, ive also been seeing this for the last two nightlies.
I havnt had much time to investigate it yet, but my strace is similar.

Changing status to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 14

15 years ago
This is still happenning to me with latest nightly -> BUT... i can get mozilla
to run by removing libqfaservices.so, after that it functions perfectly. I would
presume custom installing and unchecking "quality feedback agent" would do the
same job.

Its odd it just started happening 02/03.

suggest moving to talkback component.

Comment 15

15 years ago
I think this was caused by

  bug 193442  getting the GRE working without LD_LIBRARY_PATH on linux

so reassigning to Doug.

Using my own CVS builds and bonsai:

  2003-02-28-00  build works
  2003-02-28-13  landing of bugs 193442,191415
  2003-03-02-08  crash with segfault
  ...
  2003-03-03-04  crash with segfault
  2003-03-03-13  backout of bugs 193442,191415
  2003-03-04-12  build works
  2003-03-04-19  relanding of bug 193442
  2003-03-04-23  crash with segfault
  ...
  2003-03-13-00  crash with segfault
Assignee: asa → dougt

Comment 16

15 years ago
please remove older versions of mozilla from your system and download 1.3.  This
will fix the problem.

Comment 17

15 years ago
I have been unable to run the CVS version for weeks; segfault at startup.
Today I gdb'ed a run, and found that the segfault occurred in a call to
free().  I removed --with-xpcom-lea, which I've been using for five months,
from my configure options, and then it worked again!

Comment 18

15 years ago
lea memory allocator has been busted for 2 years (bug 73053)

Comment 19

15 years ago
is anyone still seeing this?

I am going to toss this over to talkback as it appears the crash is caused from
libqfaservices.so
Assignee: dougt → namachi
Component: Browser-General → Talkback
QA Contact: asa → chofmann

Comment 20

15 years ago
*** Bug 204585 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
Created attachment 122646 [details]
Segmentation Fault with alberto user

Comment 22

15 years ago
Created attachment 122647 [details]
Bus error with root user

Comment 23

15 years ago
I opened a bug yesterday (204585) and has been considered as a duplicate of
this.  I've read this bug and really I donṫ know the solution yet. The problem
explained in bug 204585 is with my user alberto but if I try to run mozilla 1.3
with root user the error messge is similar but not the same:
/usr/local/mozilla/run-mozilla.sh: line 454:  1427 Bus error              
"$prog" ${1+"$@"}

I've deleted the previous 1.3 installation and I've installed it again the 1.3
but the problem is still there and the message error is the same.
Could anyone tell me how to use again mozilla 1.3? Fortunately the Mozilla 1.0.1
works ok.
In the attachment you can see result of execute 
LD_LIBRARY_PATH=`pwd` gdb mozilla-bin
with root and alberto users
(Reporter)

Comment 24

15 years ago
I have finally fixed the problem.
You have to change the path in /usr/bin
In /usr/bin the patch was directed to where it was installed when I installed
the distro
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 25

15 years ago
reopening.  this is not FIXED, which is reserved for bugs fixed by code changes

> You have to change the path in /usr/bin

what?  there is no path in /usr/bin

> In /usr/bin the patch was directed to where it was installed when I installed
> the distro

there was no patch.  if you are talking about installing Mozilla to /usr/bin,
that is all sorts of bad, and will probably end in you reinstalling your OS.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 26

15 years ago
Really I do not understand either what it means the solution given by albert
(comment 24), I agree the bug must be reopened because I have still the problem
and I have no idea how to solve it.

Comment 27

15 years ago
I just happened to get hit by this bug... It crashed and dumped core on my
Gentoo 1.4 system (newly installed last week, mozilla installed in a user home,
and no ~/.mozilla). The backtrace in all the core dumps (I tried four times) is
the same:

(gdb) where
#0  0x417439f5 in FCModuleMgr::FindRange ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#1  0x417438c8 in FCModuleMgr::GetNextModule ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#2  0x41743989 in FCModuleMgr::FindModule ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#3  0x41742140 in nsICategoryManager::GetIID ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#4  0x41742238 in nsICategoryManager::GetIID ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#5  0x41742624 in FCInitialize ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#6  0x4174175f in nsQfaServicesImpl::StartService ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#7  0x41741878 in nsQfaServicesImpl::Observe ()
   from /home/newtonb/mozilla/components/libqfaservices.so
#8  0x4171dd29 in NSGetModule ()
   from /home/newtonb/mozilla/components/libembedcomponents.so
#9  0x080598c6 in getCountry ()
#10 0x0805a77b in main ()
#11 0x4102ada7 in __libc_start_main () from /lib/libc.so.6

After renaming libqfaservices.so (as suggested in this bug), it worked (no crash
on startup, at least).

So, I removed ~/mozilla, ~/.mozilla, and reinstalled with only Browser,
Mail/News, and PSM (as suggested in this bug too). It didn't crash. So, I blame
QFA (since the previous install was with 'Typical - Brower and Mail/News').

This bug is probably distribution specific (I recall running 1.4b on Debian
testing with no problem and full install).

Comment 28

15 years ago
In case it wasn't clear, the version I tried is
mozilla-i686-pc-linux-gnu-1.4b-sea.tar.gz

Comment 29

15 years ago
I think the summary should be changed to "Crash at startup in libqfaservices.so
[@FCModuleMgr::FindRange]" which is both more explicative and easier to find,
but I can't change that field. Can someone else do it?

Comment 30

15 years ago
This also happens for me.  It start happening in 1.3 so I installed 1.4rc1 and
it stopped for a while.  Now 1.4rc1 is doing it:

 > catchsegv /usr/local/mozilla/mozilla
/usr/local/mozilla/run-mozilla.sh: line 454:  2271 Segmentation fault     
"$prog" ${1+"$@"}
*** Segmentation fault
Register dump:

 EAX: 407783cc   EBX: 4008b39c   ECX: 407a1200   EDX: 08269908
 ESI: 08269908   EDI: bfffd190   EBP: bfffd118   ESP: bfffd0fc

 EIP: 4007e470   EFLAGS: 00010246

 CS: 0023   DS: 002b   ES: 002b   FS: 0000   GS: 0007   SS: 002b

 Trap: 0000000e   Error: 00000006   OldMask: 80000000
 ESP/signal: bfffd0fc   CR2: 547deae5

 FPUCW: ffff037f   FPUSW: ffff0020   TAG: ffffffff
 IPOFF: 406bc1c9   CSSEL: 0023   DATAOFF: bfffd368   DATASEL: 002b

 ST(0) 0000 0000000000000000   ST(1) 0000 0000000000000000
 ST(2) 0000 0000000000000000   ST(3) 0000 0000000000000000
 ST(4) 0000 8000000000000000   ST(5) 0000 e000000000000000
 ST(6) 0000 8000000000000000   ST(7) 0000 8000000000000000

Backtrace:
/usr/local/mozilla/libmozjs.so(js_InitStringGlobals+0x0)[0x4007e470]
/usr/local/mozilla-1.4rc1/components/libxpconnect.so[0x40778404]
/usr/local/mozilla-1.4rc1/components/libjsd.so[0x40616333]
/usr/local/mozilla/libxpcom.so(NS_CreateServicesFromCategory__FPCcP11nsISupportsT0+0x526)[0x406f75ca]
/usr/local/mozilla/libxpcom.so(AutoRegisterImpl__22nsComponentManagerImpliP7nsIFilei+0x9e)[0x406fdd46]
/usr/local/mozilla/libxpcom.so(AutoRegister__22nsComponentManagerImplP7nsIFile+0x5f)[0x406fe4cb]
/usr/local/mozilla/libxpcom.so(NS_InitXPCOM2+0x554)[0x406bba8c]
/usr/local/mozilla/mozilla-bin(NS_InitXPCOM2+0x35)[0x8075ae5]
/usr/local/mozilla/mozilla-bin(GRE_Startup+0x9d)[0x8075ded]
/usr/local/mozilla/mozilla-bin(main+0x5e)[0x805b08a]
/usr/local/mozilla/mozilla-bin(__libc_start_main+0xa4)[0x420158d4]
/usr/local/mozilla/mozilla-bin(gtk_button_new_with_label+0x51)[0x8056e41]


I noticed that this is a different backtrace, so this might be a different bug.
  I'm running mozilla-i686-pc-linux-gnu-1.4rc1-sea.tar.gz on RH 8.0.  I still
have a ~/.mozilla dir.

Comment 31

15 years ago
is this still a problem using 1.5b?
(lowering severity since there is a workaround)
Severity: blocker → critical

Comment 32

14 years ago
The problem is still there with Mozilla 1.4. Regarding 1.5, really I don't dare
to use it.Fortunately the 1.0.2 works OK. 

Updated

9 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard

Comment 33

8 years ago
Talkback is gone.  It has been replaced with Breakpad.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.