bookmarks don't work with first window opened with bookmark manager

VERIFIED FIXED

Status

()

Firefox
Bookmarks & History
--
minor
VERIFIED FIXED
16 years ago
12 years ago

People

(Reporter: bugzilla, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

clicking bookmarks in quick bookmarks or in bookmarks pulldown has no effect in
a unique bookmarks-manager spawned window:
open phoenix
open bookmark manager
close browser window(s)
open URL from bookmark manager (opens a new browser window)
bookmarks in that window are unusable
also, "open in tabs" doesn't appear in quickbar groups

Reproducible: Always

Steps to Reproduce:
1. open phoenix
2. open bookmark manager
3. close browser window(s)
4. open URL from bookmark manager (opens a new browser window)


Actual Results:  
bookmarks appeared, but were unusable (no effect by clicking, but the menus open
fine)
"open in tabs" does not appear

Expected Results:  
either not show menus (bad) or have the bookmarks work as normal (good)

new phoenix install, previous install of Moz 1.2.1

Comment 1

16 years ago
Reproduced with 2003022808
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030228 Phoenix/0.5

After these steps, I can't access using [Bookmarks] on Menu-bar and
Bookmarks-toolbar.
But still accessible with Bookmarks Sidebar and Bookmark Manager.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

16 years ago
Marking as NEW and correcting OS setting.
OS: Windows 2000 → All
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 4

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030726
Mozilla Firebird/0.6.1
Bookmarks in toolbar also not responsive if you just close the open browser
window and then open a new one.

Comment 6

15 years ago
We have reproduced this bug on Mac OS X 10.2.8 as well with Firebird v0.7.

Updated

15 years ago
Hardware: PC → All

Comment 7

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20031026
Firebird/0.7+

Can anyone else confirm that this is fixed? I'm wondering if some of the Mac
reports of this bug were actually due to bug 223331, which was fixed about a
week ago, and that the Windows version has been fixed for longer.
Seems to be resolved on 10/27, definitely post 0.7 fix, probably part of pch's
bookmarks cleanup checkins had an intended (or unintended) effect.  Either way,
this is fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

15 years ago
This was marked as fixed, but I just reverified it's existence in FireBird 0.7
for Windows.  I am running XP.  This was an upgrade, but I did delete my profile
and start anew, so I don't think this is my mistake.  I cannot explain my
differing result.  Perhaps you had another browser window hidden somewhere?  
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 10

15 years ago
Woops, sorry - I misread previous comments as asserting that this was fixed IN
0.7 instead of post.  Sorry about the noise.  
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
verified fixed 2003-11-09
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.