[ASSERTION] 4.x NPP_WriteReady = 0 should not be an error

RESOLVED DUPLICATE of bug 89270

Status

()

RESOLVED DUPLICATE of bug 89270
16 years ago
16 years ago

People

(Reporter: tenthumbs, Assigned: peterlubczynski-bugs)

Tracking

({assertion})

Trunk
x86
Linux
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
If 1) a 4.x plugin can only accept data at some fixed maximum rate, 2) the
network connection is faster than that rate, and 3) the plugin uses NPP_Write
and NPP_WriteReady then the plugin may well return 0 for NPP_WriteReady because
it cannot currently accept more data.

Mozilla treats this as an error, throws the assertion 

###!!! ASSERTION: WriteReady returned Zero: 'numtowrite', file
ns4xPluginInstance.cpp, line 413
Break: at file ns4xPluginInstance.cpp, line 413

and then cancels the stream.

The old 4.x plugin docs don't say zero is an error. It's also fairly common for
streams to block for a while. Mozilla's behavior seems incorrect.

I've also done a few test with a rate-limited proxy server and it certainly
appears that if the network is slower than the plugin then mozilla will succeed.
Success for a slow connection and failure for a fast one also seems incorrect.
(Reporter)

Comment 1

16 years ago
Setting the assertion keyword.
Keywords: assertion
(Assignee)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 89270 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.