Manipulating text with document.getElementById(id).innerHTML does not work when used together with positon:fixed

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

When manipulation a span tag (eg. replacing text) and this span is in a table
which enclosed by a div with position:fixed the old text is deleted but the new
text is _not_ displayed. Seems to be a new issue with Mozilla 1.3(b), worked
fine with Mozilla 1.2.1. See attached example code for this issue.

Reproducible: Always

Steps to Reproduce:
Use attached demonstration file.
Actual Results:  
Replacement text is not displayed with Mozilla 1.3b.

Expected Results:  
Show up replacement text (in demonstration file: "newtext" should apear)

If position:fixed is removed, everything works like expected. It seems to depend
on the table, too.
(Reporter)

Comment 1

16 years ago
Created attachment 116057 [details]
Demonstration html file
Is this only a problem with position:fixed or also with position:absolute?  Does
the problem disappear if you give the fixed div a pixel width?

If the answers are "it's a problem with absolute" and "yes", then is this a
problem with a trunk build from tomorrow or later?  A table reflow bug was fixed
today that may address this issue...
(Reporter)

Comment 3

16 years ago
The bug appears only with position:fixed and does not seem to depend on width.
When you replace position:fixed with position:absolute everything works like
expected (of course with position not fixed then).
Hmm.. actually, this worksforme with linux trunk build 2003-02-26-08...

Comment 5

16 years ago
Created attachment 116077 [details]
testcase

Comment 6

16 years ago
wfm win98 2003-02-28-14
(Reporter)

Comment 7

16 years ago
Just tested it with the latest nightly (2003030222). Bug seems to be fixed.
marking so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.