SetData of object element is not operated.

VERIFIED DUPLICATE of bug 192891

Status

()

VERIFIED DUPLICATE of bug 192891
16 years ago
16 years ago

People

(Reporter: somyung, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
Build Identifier: Mozilla 1.0

Example::: 

<html>
<head>
<script>
function changeImage() {
  document.getElementById("myObj").data = "btn_left_over.gif"
}

</script>
</head>
<body>
<object id="myObj" data="btn_left_off.gif" width=100 height=100></object>
<form>
<input type="button" value="changeImg" onclick="changeImage();">
</form>
</body>
</html>

++++++++++++++++++++++++++++


If the button is clicked, image have to be changed to btn_left_over.gif.
But, Actually... image is not changed.
I think that this result is  because setData() of object element is wrong. 

SetData should be implemented correctly.



Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Actual Results:  
image is not changed to btn_left_over.gif.

Expected Results:  
image should be changed to btn_left_over.gif.
Over to plug-ins; this is a known bug in <object>'s handling of loading from
frames instead of content....
Assignee: jst → peterlubczynski
Component: DOM HTML → Plug-ins
QA Contact: desale → shrir
(Assignee)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 192891 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Yeah, that's it.  Thanks, Peter!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.