Mozilla crashes with invalid page fault in XPCOM.DLL after installation

RESOLVED INVALID

Status

()

Core
XPCOM
--
blocker
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Timothy Lee, Assigned: dougt)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030228 Phoenix/0.5
Build Identifier: http://ftp34.newaol.com/pub/mozilla/nightly/2003-03-02-08-trunk/mozilla-win32-installer-sea.exe

After installing the latest nightly (20030302), Mozilla creates the proper
program group in start menu and shortcuts on the Windows desktop, but crashes
immediately on startup.  Clikcing on the shortcuts lead to the same result.

Reproducible: Always

Steps to Reproduce:
1.Remove any old installations, including any existing profiles
2.Install Mozilla

Actual Results:  
Mozilla causes an invalid page fault.  The following information is reported by
Windows:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:61e1aded.
Registers:
EAX=4d7a6f6d CS=0167 EIP=61e1aded EFLGS=00010202
EBX=00000000 SS=016f ESP=0065f5d0 EBP=0065f5f4
ECX=00785b04 DS=016f ESI=61e1eba0 FS=568f
EDX=74736564 ES=016f EDI=007a4370 GS=0000
Bytes at CS:EIP:
8b 00 3b c3 74 21 33 f6 80 38 00 74 1a 8b 4d 08 
Stack dump:
00000000 80000000 00785590 61e1eba0 00785ae0 00000000 00000001 00785ae8 00000000
0065fa48 61dfdf65 00785594 00785ae0 007a45e0 007a0b80 61e211b8
 

Expected Results:  
Mozilla should start and show a browser window.
(Reporter)

Updated

15 years ago
Flags: blocking1.4a?
(Reporter)

Comment 1

15 years ago
Sorry, problem was caused by spellchecker component from Mozdev.  Marking as
INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID

Updated

15 years ago
Flags: blocking1.4a?
You need to log in before you can comment on or make changes to this bug.