Closed Bug 19571 Opened 20 years ago Closed 20 years ago

dragging or copying text/plain data sometimes has garbage at end

Categories

(Core :: XUL, defect, P2)

PowerPC
Mac System 8.5
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: mikepinkerton, Assigned: mikepinkerton)

References

Details

(Whiteboard: fix in hand, waiting for approval)

simon helped me find a bug in nsPrimitiveHelpers::CreatePrimitiveFromData where i
assume the data from the drag manager is null terminated, but it obviously isn't,
causing extra garbage to be tacked on the end.
Status: NEW → ASSIGNED
Priority: P3 → P2
Target Milestone: M12
p2, m12.
QA Contact: claudius → elig
Drag & Drop bug; QA Assigning to self. (Pinkerton, please feel free to directly
QA Assign these to me in the future.)
Depends on: 20066
Mike, could this also occur on text pasted in from external apps?(e.g.
Communicator)
Summary: dragging text/plain data sometimes has garbage at end → dragging or copying text/plain data sometimes has garbage at end
eli, absolutely.
[thanks!]
Whiteboard: fix in hand, waiting for approval
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
fixed.
Blocks: 20870
Status: RESOLVED → VERIFIED
Verified fixed on 1999120708 (Mac OS commercial) and 1999120608 (Win32
commercial). Unable to verify on 1999120708 (Linux commercial) since drag & drop
doesn't appear to even work at all.

Performed verification by using pinkerton-supplied test case of copying the URL
proxy icon to the URL field.

(E-mailed pinkerton about a side-issue, specifically, that the URL proxy icon
copies the text contents of the URL field, rather than the URL of the web page
itself. Unsure if this is an intended deviation from 4.x.)
*** Bug 20945 has been marked as a duplicate of this bug. ***
No longer blocks: 20870
You need to log in before you can comment on or make changes to this bug.