page sometimes renders with missing list items

VERIFIED WORKSFORME

Status

()

P2
major
VERIFIED WORKSFORME
16 years ago
15 years ago

People

(Reporter: mark, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030210

The menu boxes are styled <ul> lists within a couple of divs. All code is clean
and validates.

Occasionally, especially with uncached copies (it seems), the menu box is
rendered with the last few menu items missing. At time of writing (3/3/2003) the
"main" box has ten items, from "home" to "other". This also happens with other
"sub-menu" boxes around the site.

Rendering is as if the latter items were missing, but View Page Source shows 
complete code. Reloading often corrects the problem, but not necessarily first time.

Reproducible: Sometimes

Steps to Reproduce:
1. Load up the URL.
2. View page source.
3. Compare the <li> items in the mbox div at the bottom with the rendered output.

Actual Results:  
Occasionally rendered with missing items.

Expected Results:  
Shown all list items.

I've rated it as "Major" because potentially critical information is silently
discarded before rendering. Just because my home page isn't mission-critical
doesn't mean this bug couldn't have bigger implications.

Comment 1

16 years ago
I've tried catching this bug but am having trouble, even tho I have the same
browser as you. Could you try catching it when it appears and grab a screen dump
and also do a "view source" and see if the source is complete?

Comment 2

16 years ago
works for me with
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030302

Updated

16 years ago
Priority: -- → P2
(Reporter)

Comment 3

16 years ago
This is infuriating. I cannot reproduce this problem now.

I'll keep trying, but unless anyone else can reproduce it, should we close this
in a couple of weeks (say 19 March)?
(Reporter)

Comment 4

16 years ago
Created attachment 116742 [details]
Screenshot showing missing ul

Mozilla 1.3b/Win2kSP3
(Reporter)

Comment 5

16 years ago
Created attachment 116743 [details]
HTML source of file from which screenshot is taken

HTML source used for screenshot 116742
(Reporter)

Comment 6

16 years ago
Created attachment 116744 [details]
CSS source for screenshot

CSS source for HTML 116743, for screenshot 116742
(Reporter)

Comment 7

16 years ago
Got it. The failure mode is slightly different from before - the entire <ul> did
not display. I tried to View Source, but Mozilla crashed. Due to the page
length, I can't confirm that the source is complete as I couldn't see the
footer. Past occurrences have showed the footer: I'll keep trying to capture one
of those. As usual, this is *very* intermittent.

It's worth noting that since my original bug submission when the last n list
items were missed, I've replaced an unnecessary nesting of <div> in the menus
with selector code, and now a complete <ul> is missing.

I've just attached a screenshot and accompanying source code in case I make any
updates. The page does validate for XHTML and CSS.
(Reporter)

Comment 8

16 years ago
Created attachment 116746 [details]
Screenshot of error with source view

At last - a photo of the bug as reported. Notice that the top menu box only
shows three list items, whereas the code shows thirteen. Source download is
complete, and the following menu boxes are rendered correctly.

Maximizing the browser to try to get a bigger shot showing the footer caused a
re-render which corrected the problem. This isn't an acceptable workaround
though, as the user has no way of knowing that information is missing.
(Reporter)

Comment 9

16 years ago
Bug still present in 1.3 release.
(Reporter)

Comment 10

16 years ago
Created attachment 118278 [details]
Another screenshot of the bug, from a different site

Another error screenshot from one of my other sites. Note more list items in
source window than are actually displayed. A reload fixed the display. HTML and
CSS both validate. No CSS2 generated content in this example, unlike the
previous one.

Comment 11

16 years ago
I cannot reproduce the bug

reporter, can you select the part w/ the problem, right click, choose
"view selection source", and paste the generated source code?
Summary: page renders with missing list items → page sometimes renders with missing list items

Comment 12

15 years ago
Haven't experienced the problem in Moz 1.4 or Firebird 0.7. Suggest it should be
marked as FIXED - will reopen if it reoccurs.

Comment 13

15 years ago
Per comment 12:

-> WORKSFORME

(If the reasons a bug works is unclear, it has 'never been' FIXED ;-))
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

15 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.