Browser does not properly detect JRE plugin (works in IE!)

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
major
RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: jason, Assigned: Peter Lubczynski)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2) Gecko/20021120 Netscape/7.01

Netscape/Mozilla does not detect that Sun's JRE 1.3.1 is installed after
installation of 1.4.1 for an applet.
Here is the scenario to reproduce:
- uninstall all JRE's from PC (start clean)
- run test html page containing applet (see code below) -> netscape prompts for
installation of 1.3.1 as specified via the static versioning MIME type in
"<Object>" tag of html (see below)
- install JRE 1.3.1
- run test html page containing applet (see code below) -> everything should
come up as expected
- install JRE 1.4.1 
- run test html page containing applet (see code below) -> netscape again
prompts for installation of JRE 1.3.1 even though 1.3.1 has already been installed

It seems as if the installation of JRE 1.4.1 somehow confused Netscape such that
it no longer thought 1.3.1 was installed.  This is a problem because our applet
will crash if used with anything other than JRE 1.3.1
This can be reproduced with any small applet and has been tried using the
"<Applet>" and "<EMBED>" tags as well.

Here is the code that specifies static versioning for JRE 1.3.1 and which should
bring up the applet.

<OBJECT type="application/x-java-applet;jpi-version=1.3.1"
	archive="TestApplet.jar"
	WIDTH="100%" HEIGHT="100%">
   <PARAM NAME="CODE" VALUE="com.testapplet.TestApplet">
</OBJECT>

Thanks for the help.
jason

Reproducible: Always

Steps to Reproduce:
1. uninstall all JRE's from PC (start clean)
2. run test html page containing applet-> netscape prompts for installation of
1.3.1 as specified via the static versioning MIME type in "<Object>" tag of html
 (see description)
3. install JRE 1.3.1
4. run test html page containing applet-> everything should come up as expected
5. install JRE 1.4.1 
6. run test html page containing applet-> netscape again prompts for
installation of JRE 1.3.1 even though 1.3.1 has already been installed


Actual Results:  
browser prompts, again, for installation of JRE 1.3.1 even though it has already
been installed

Expected Results:  
Detected that JRE 1.3.1 was already installed and proceed to download/open applet
(Assignee)

Comment 1

16 years ago
Does it work with TYPE="application/x-java-applet;version=1.3.1" ?

Can you copy/paste the output from about:plugins and attach it in a file here?

It's possible the 1.3.1 installer didn't recognize the Mozilla plugins folder so
the browser reverted to the newest JRE installed on the system. Try setting the
environment variable MOZ_PLUGIN_PATH to point the Java 1.3.1 bin directory that
has the plugins and restart the browser.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
Target Milestone: --- → Future
(Reporter)

Comment 2

16 years ago
Created attachment 116145 [details]
about plugins info for Netscape

Here's the about information for Netscape plugins.  This is after 1.3.1 and
1.4.1 are both installed.

TYPE="application/x-java-applet;version=1.3.1" will work but uses 1.4.1.  I
need it to work with 1.3.1 only, even if a more recent plugin is installed.  In
this case it needs to work using "jpi-version".
(Reporter)

Comment 3

16 years ago
Peter - any additional thoughts on this?
(Assignee)

Comment 4

16 years ago
The 1.3.1 installer did not find Mozilla. Set MOZ_PLUGIN_PATH to point to where
the 1.3.1 np Java DDLs are located.
(Reporter)

Comment 5

16 years ago
This is not a valid workaround for applets.  Are you saying every client in 
this situation that uses our applet will have to set this path to assure 
mozilla finds 1.3.1?  

The whole point of using static versioning is so that you can specifiy which 
plugin the browser should be using without any intervention from the client, 
unless it isn't installed, of course.

Would you agree then that this is a bug in Mozilla or, perhaps, it is a bug in 
Sun's 1.3.1 (does not properly install?)  I would say the former since IE works 
properly in this scenario.
(Reporter)

Comment 6

16 years ago
Created attachment 116337 [details]
about plugins info for Netscape - 2

After setting MOZ_PLUGIN_PATH to point to the plugins directory Mozilla still
uses JRE 1.4.1 instead of 1.3.1 as it seems the "About Plugins" would indicate.
 The file is attached.
Please let me know if you have a work-around for this bug as time is pushing us
to the point where we may have to nix plans to support Netscape.

Thanks.
jason
(Assignee)

Comment 7

16 years ago
I see a "application/x-java-applet;jpi-version=1.3.1" in your about:plugins 
and it shows up first, as expected. Do you still get a default plugin or does 
it just not show up? Set NSPR_LOG_MODULES=Plugin:8 and 
NSPR_LOG_FILE=c:\log.file to get browser debug plugin log.

The Sun installers doesn't always recognize Mozilla but should recognize 
Netscape. Netscape 6 even shipped with JRE 1.3.1. You often have to copy the 
DLL's but setting MOZ_PLUGIN_PATH is a shortcut that won't mess up 
uninstallers. Also see bug 185000, but the current patch looks to be only for 
UNIX.
(Reporter)

Comment 8

16 years ago
Created attachment 116344 [details]
plugin log

The applet ends up being run in JRE 1.4.1 even though it appears that it should
be 1.3.1 as you noted and as seen in the "About Plugins".

Attached is the log of the startup of my applet.
(Reporter)

Comment 9

16 years ago
Any additional thoughts?
QA Contact: shrir → plugins
JRE1.3x is old, please reopen if this issue still happens
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.