Sends IMAP/POP username to SMTP server

RESOLVED DUPLICATE of bug 90507

Status

SeaMonkey
MailNews: Account Configuration
--
major
RESOLVED DUPLICATE of bug 90507
15 years ago
13 years ago

People

(Reporter: Shoshannah Forbes, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.2) Gecko/20021216
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:1.0.2) Gecko/20021216

I have an IMAP account that does not have SMTP, and an SMTP server that I need
to use SMTP AUTH to use.
I have a diffrent user name for the IMAP and for the SMTP.
Mozilla insisits on attempting to use the IMAP user name as the user name in the
SMTP server.

this prevents me from sending any email from the IMAP account


Reproducible: Always

Steps to Reproduce:
1. set up a POP/SMTP account where the SMTP uses SMTP auth with user name a
2. set up an IMAP account with user name b
3. Try to use the SMTP server in oder to send mail from the IMAP account

Actual Results:  
mozilla insists on using user name b with the SMTP server

Expected Results:  
Mozilla should use the user name in the SMTP settings, not the one in the IMAP
settings

Iam attaching my prefs file
(Reporter)

Comment 1

15 years ago
Created attachment 116106 [details]
My prefs file

Comment 2

15 years ago
Moz 1.3b (2003021008) / Win2K

I've experienced similar problems with pop3 and authenticated smtp; I'm assuming
it's the same bug.

I worked around it by setting,
       Mail & Newsgroup Acct Settings | [acct name] | Advanced
to,
       'Always use default server'.


If I look in Mail&News Acct Settings | Outgoing (SMTP) | Advanced, I see the
same smtp server listed ~ once for each pop account, and each listing has the
wrong username as the reporter described.

Hardware and OS -> All
Changing summary to include POP accounts also.
OS: Mac System 9.x → All
Hardware: Macintosh → All
Summary: Wrong user name sent to SMTP server from IMAP account → Sends IMAP/POP username to SMTP server
(Reporter)

Comment 3

15 years ago
>I worked around it by setting,
  
Workaround doesn't work for me :-(
Any way to be able to send email with that account?
(Reporter)

Updated

15 years ago
Depends on: 178672
(Reporter)

Comment 4

15 years ago
The SMTP server I use can work without auth, however, that workaround fails due
to bug #195749

Now I am left with no way to send Email using that account :-(
(Reporter)

Comment 5

15 years ago
correction: bug #178672 fails  my workaround

Comment 6

15 years ago
Soshannah - 

I found a way to do it before I discovered my trick in comment #2.

Unfortunately, I don't remember the details, but try,
   - Editing the login directly in Mail&News prefs | SMTP settings | Advanced ...
   - Create an Moz account just for sending mail.  Set everything the same as
the 'real' account, except the pop/imap id (set to the smtp id) and don't use it
to check mail.
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey
Main issue(duplicate SMTP entries) of this bug is already fixed by Bug 90507.
So closing as DUP of Bug 90507.

See Bug 222388 for request to change deafult of account's SMTP choice to "Always
use default SMTP server" (workaround by commment #2).
See Bug 202468 for unkind/confusiong SMTP related UI. 
Big UI improvement is in progress under Bug 202468.
	

*** This bug has been marked as a duplicate of 90507 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.