Find as you type menu items ghosted/disabled when form element has focus

RESOLVED WONTFIX

Status

SeaMonkey
Find In Page
RESOLVED WONTFIX
15 years ago
10 years ago

People

(Reporter: Stefan Borggraefe, Assigned: Aaron Leventhal)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030303
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030303

The new menu items for Find As You type are ghosted when a form element has the
focus. I think this is quite confusing for the user. Why can´t I use search the
content of a page with Find as you type when I´m using a form?
Sometimes the user may not even notice that a form element has the focus. In any
case this is not traceable for an average user.


Reproducible: Always

Steps to Reproduce:
1. Go to a web page with form elements in it, i.e. this bug report. ;-)
2. Focus a form element, for example a textarea.
3. Check the two Find As You Type menu items in the Edit Menu.

Actual Results:  
The menu items are ghosted.

Expected Results:  
The menu items should always be enabled.
looks like focusing any form element --except for radiobuttons (that's odd)--
disables the FAYT menu items. also see this on linux rh8.0 -> all.

aaronl, is this expected behavior? if so, why are radiobuttons the exception here?

i wouldn't be too surprised about this being expected, esp since Find in Page
doesn't work for textareas (an old, old bug)...
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 2

15 years ago
This is on purpose.

Right now it's just too difficult to keep / and ' from getting swallowed on mac
os x when you're enterying text, unless the menu items are disabled.
aaronl, could you explain why radiobuttons don't cause the same disabling effect?
(Assignee)

Comment 4

15 years ago
I only disabled the menu items on form controls where / or ' might be important.
They're not important on radio buttons or checkboxes.
(Assignee)

Comment 5

14 years ago
Works as expected.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.