No "save image" option on context menu for images as javascript links

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: bill_b, Assigned: bugzilla)

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

If a web developer uses an image as a javascript link (e.g. click on the image
and something happens via javascript [most common: jump to another page]), then
the context menu that appears when the user right-clicks the image does not
bring up an option to save the image. 

Reproducible: Always

Steps to Reproduce:
1. Create a web page with an image on it
2. Use the image as the basis for a javascript link (e.g. go(/foo/bar/baz.html))
3. Load the new page in Phoenix
4. Right-click on the image


Actual Results:  
No "save image" option appears in the context menu

Expected Results:  
For any image, an option to save the image should always appear on the context menu

Comment 1

16 years ago
First of all, this is not a Phoenix bug. It's a Mozilla bug. Secondly, I'm
pretty sure there is a bug filed for this. I wouldn't even be surprised if it's
already fixed.

You should read the bug filing instructions here:
http://texturizer.net/phoenix/bugs.html
Component: Menus → Browser-General
Keywords: qawanted
Product: Phoenix → Browser
Version: unspecified → Trunk
Bill, is there a page that demonstrates the problem?

Comment 3

16 years ago
Resolving due to lack of response from reporter

please reopen if the problem persists with a new build of Mozilla and you can
provide a URL that demonstrates the problem
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.