Login cookies don't work right with Safari

RESOLVED FIXED in Bugzilla 2.18

Status

()

RESOLVED FIXED
16 years ago
6 years ago

People

(Reporter: dberlin, Assigned: bbaetz)

Tracking

unspecified
Bugzilla 2.18
PowerPC
macOS

Details

(Whiteboard: [blocker will fix])

Attachments

(1 obsolete attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-us) AppleWebKit/62 (like Gecko) Safari/62
Build Identifier: 

If you use Safari with bugzilla, it continually asks you to login. It is actually setting the cookie, but the login name it puts in the cookie has a space in front of it, so when it looks it up again, it can't find it.

The cause is this line in CGI.pl:
print "Set-Cookie: Bugzilla_login= " . url_quote($enteredlogin) . " ; path=$cookiepath; expires=Sun, 30-Jun-2029 00:00:00 GMT\n";

If you change it to:
print "Set-Cookie: Bugzilla_login=" . url_quote($enteredlogin) . " ; path=$cookiepath; expires=Sun, 30-Jun-2029 00:00:00 GMT\n";



everything works fine.

Reproducible: Always

Steps to Reproduce:
confirmed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I bet Safari is sending the leading space back as part of the cookie content...
Created attachment 116151 [details] [diff] [review]
Patch

removes leading space from the cookie value
Comment on attachment 116151 [details] [diff] [review]
Patch

this is actually already included in the Auth.pm patch.  I'll dupe in a moment.
Attachment #116151 - Flags: review?(bbaetz)
Setting dependency on the Auth.pm bug.  That's about to land, and the patch
there already fixes this.
Depends on: 180642
Whiteboard: [blocker will fix]
Attachment #116151 - Attachment is obsolete: true
(Assignee)

Comment 6

16 years ago
Our cookies stuff is fragile. Using CGI.pm on that stuff is on my list after the
Auth patch goes in.
(Assignee)

Comment 7

16 years ago
Fixed as part of the auth reorg.

hyatt: since mozilla, ie, and ns4 (not to mention lynx, links, and several
others) support this, you probably want to support this for safari....
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
*** Bug 200374 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

15 years ago
Dave, this isn't fixed on bmo yet, it appears (using an apple loan laptop at linux.conf.au). Any 
chance of applying this manually?
Assignee: justdave → bbaetz
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.