Error dialog has misleading url if malformed url is entered in bar

RESOLVED DUPLICATE of bug 66183

Status

RESOLVED DUPLICATE of bug 66183
16 years ago
10 years ago

People

(Reporter: t, Assigned: hewitt)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030117
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030117

The error dialog that appears if an invalid url is entered has a confusing host
name. It displays the on-fail host name (I'm guessing it tries to append www. to
what you enter if dns lookup fails). This is confusing, since the user never
entered this hostname. It's like the www is coming from no where.

Reproducible: Always

Steps to Reproduce:
1. Open a new browser window
2. Paste this url into the url bar: http://cn-sfo1-die73-vla1.cnet:3557/?scriptID=0
3. Examine the resulting error dialog.

Actual Results:  
Error dialog appears which says "www.cn-sfo1-die73-vla1.cnet could not be found.
Please check the name and try again."

Expected Results:  
Error dialog appears which says "cn-sfo1-die73-vla1.cnet could not be found.
Please check the name and try again." Note there's no www. at the front.

*** This bug has been marked as a duplicate of 66183 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
V/dupe.
QA Contact: claudius → benc
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.