Mozilla 1.3b freezes in Win98SE shortly after visiting certain web pages

RESOLVED DUPLICATE of bug 192294

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 192294
16 years ago
14 years ago

People

(Reporter: Wolfgang Kronberg, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.3b) Gecko/20030210

On Win98SE, go to www.icq.com and wait until the page has fully loaded. Open a
new browser window (Ctrl-N) and visit any other web page. 15-30 seconds after
www.icq.com has finished loading, mozilla will freeze completely and has to be
killed via task list.
This problem will occur on many web pages, but www.icq.com is the only publicly
accesible one I found where the freeze can be reproduced always. The freeze will
occur even if the www.icq.com browser window has been closed by the user.

Reproducible: Always

Steps to Reproduce:
1. Go to www.icq.com
2. Open another browser window with Ctrl-N
3. Direct this other browser window to some other address
4. Wait up to 30 seconds

Actual Results:  
The complete mozilla application freezes and has to be killed via tasklist

Expected Results:  
Normal operation should have continued
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030228
second window directed to www.w3.org

Notably, icq.com generates many JavaScript strict warnings, particularly in the
adsWrapper.js file they reference.
(Reporter)

Comment 2

16 years ago
Alex: how do you get these js warnings? I've kept the JS console open while
loading www.icq.com, but no warning appeared.
The only thing which I see in the js console is an error which is there from
startup:

Error: redeclaration of const MSG_FOLDER_FLAG_TRASH
Source File: chrome://messenger/content/commandglue.js

Could it be that this error is somehow responsible for my problems? That it is
perhaps destabilizing my js engine? If yes: how to fix it?
from the 1.3bRelease notes under the "New Additions to the Release Notes" section:
Windows 95, 98 and ME users are experiencing regular application hangs. This
doesn't appear to impact NT, 2K or XP. (bug 192294)

from your report: 
This problem will occur on many web pages

and why should this not be a dupe ?
You must know about bug 192294 because you MUST read the release notes before
you file a bug. (or you would waste our time)
(Reporter)

Comment 4

16 years ago
matti: I *did* read the release notes, including the then-available comments on
bug 192294, on downloading the beta. I did not review the current status of
192294, however, before posting this bug (I only searched for Win98 & freeze),
for which I apologize.

I reluctantly got myself the latest nightly (1.4.0-...), and the bug
disappeared. So it probably *was* just a dupe after all. I suggest marking it as
such.

I can understand that the countless dupes to bug 192294 are driving you crazy.
Nevertheless, you are not the only one whose time is wasted: it took me many
hours to find a way to make this bug 100% reproducible before reporting it. The
same happened to many other people, obviously. One lesson of this for the future
might be that it is not wise to release a version called "beta" to the public
which containes a known bug as severe as this one, even if you tell about it in
the release notes.
Many developers and also testers like me don't use win9x based systems and we
found the real problem very late.
staff@mozilla.org released 1.3b with this bug because it's only a beta build.
(the facts : i pointed Asa to bug 192294 in that moment as they tagged the 1.3b
release)


*** This bug has been marked as a duplicate of 192294 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.