If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

unstyled XML display element collapse broken

RESOLVED FIXED

Status

()

Core
XML
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: kyles, Assigned: sicking)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
blocking1.3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed1.3)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030303
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030303

1.3 branch build:
load up an unstyled XML file
click on the dash to collapse node
note that nothing happens

note that this works with the 1.3beta build

Reproducible: Always

Steps to Reproduce:
Seeing this on current linux trunk too.  This seems to have regressed between
2003-02-14-08 and 2003-02-14-22 builds, but I see no checkins in that range that
would be likely candidates for regressing this....
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.4a?
Flags: blocking1.3?
Keywords: regression
OS: Windows 2000 → All
Hardware: PC → All
Created attachment 116269 [details] [diff] [review]
patch to fix

the problem is that we nowadays don't target events at textnodes but at the
textnodes parent.
Attachment #116269 - Flags: superreview?(bzbarsky)
Attachment #116269 - Flags: review?(jkeiser)
Comment on attachment 116269 [details] [diff] [review]
patch to fix

r+sr=me; if you want to be really cool, you could check the node type before
getting the parent... ;)
Attachment #116269 - Flags: superreview?(bzbarsky)
Attachment #116269 - Flags: superreview+
Attachment #116269 - Flags: review?(jkeiser)
Attachment #116269 - Flags: review+
Comment on attachment 116269 [details] [diff] [review]
patch to fix

Right now prettyprinting is very broken. The fix is extreamly safe and will
only affect prettyprinted pages
Attachment #116269 - Flags: approval1.3?
Reassigning to Jonas.
Assignee: heikki → bugmail
Any other places in the tree need similar fixing?

/be
Flags: blocking1.3? → blocking1.3+

Comment 7

15 years ago
Comment on attachment 116269 [details] [diff] [review]
patch to fix

a=asa (on behalf of drivers) for checkin to the 1.3 branch. Time is short and
we won't hold for this but it if makes it into the branch before we make final
builds that'd be nice.
Attachment #116269 - Flags: approval1.3? → approval1.3+
I searched LXR for "originalTarget.parentNode" and found one other instance in
D&D code, is this broken without a similar fix?:

http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/content/nsDragAndDrop.js#114
checked in on the 1.3 branch
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
jkeiser is working hard at putting out fires caused by the evanttarget change.
I created bug 196239 to track similar problems elsewhere.

Updated

15 years ago
Whiteboard: fixed1.3

Updated

15 years ago
Flags: blocking1.4a?
You need to log in before you can comment on or make changes to this bug.