URL is relative has no effect when adding a page background

RESOLVED DUPLICATE of bug 167262

Status

RESOLVED DUPLICATE of bug 167262
16 years ago
14 years ago

People

(Reporter: mozilla06b, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021130

Editing a page to add a background and choosing a file for the background and
clicking on the "URL is relative to page location" check box has no effect. When
the page is saved, the url for the background becomes a file:// URL.

Even if you open the html editor and change the URL to a relative URL, when the
page is saved, it reverts back to a file:// URL. 

Reproducible: Always

Steps to Reproduce:
1. Open the Format->Page Colors and Background menu 
2. In the pop up, choose a file to use as the background.
3. Click the "URL is relative to page location" check box.
4. Save the page.
5. Check the html code. The URL for the background will be an file://<complete
path and file name> absolute URL.

Actual Results:  
When the page is put on the server, the background is not shown when it is
broused unless, by shear chance, the user has a file by teh same name in the
same path.

Since brousing from the composer will have the file in the proper location, the
page looks correct for the creator of the page edit or if the page is broused by
opening a file on the computer that was used to create the page.

Expected Results:  
If the "URL is relative to page location" check box is clicked, the background
URL should be a relative URL.

A workaround it to open the html page in a text editor like kwrite, emacs, or vi
and change the backgroun URL to the relative location. This has to be done EVERY
time the page is edited in Composer since Composer will change the relative URL
to an absolute file://<complete path and file name> URL when the page is saved.

Comment 1

16 years ago
This bug is a duplicate of bug 167262.

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 167262 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.