Trunk crash [@ RDFServiceImpl::GetResource]

VERIFIED DUPLICATE of bug 196094

Status

()

Core
RDF
--
critical
VERIFIED DUPLICATE of bug 196094
16 years ago
16 years ago

People

(Reporter: jay, Assigned: Robert John Churchill)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Looks like this crash first appeared with 2/25 MozillaTrunk builds.  There have
been a few here and there since then.  I don't see any crashes with Mozilla 1.3
Beta...so this seems to be a new regression:

RDFServiceImpl::GetResource   9 
BBID range: 17573876 - 17730612
Min/Max Seconds since last crash: 2 - 62312
Min/Max Runtime: 3 - 62312
Crash data range: 2003-02-27 to 2003-03-04
Build ID range: 2003022516 to 2003030308

Stack Trace: 

	 RDFServiceImpl::GetResource
[c:/builds/seamonkey/mozilla/rdf/base/src/nsRDFService.cpp  line 1025]
	 nsBookmarksService::CreateBookmark
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 2758]
	 nsBookmarksService::CreateBookmarkInContainer
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 2823]
	 nsBookmarksService::ParseFavoritesFolder
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 3324]
	 nsBookmarksService::ParseFavoritesFolder
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 3301]
	 nsBookmarksService::ImportSystemBookmarks
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 3367]
	 nsBookmarksService::HandleSystemBookmarks
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 3383]
	 nsBookmarksService::HasAssertion
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 3978]
	 CompositeDataSourceImpl::HasAssertion
[c:/builds/seamonkey/mozilla/rdf/base/src/nsCompositeDataSource.cpp  line 1143]
	 CompositeDataSourceImpl::OnAssert
[c:/builds/seamonkey/mozilla/rdf/base/src/nsCompositeDataSource.cpp  line 1469]
	 nsBookmarksService::OnAssert
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 5595]
	 InMemoryDataSource::Assert
[c:/builds/seamonkey/mozilla/rdf/base/src/nsInMemoryDataSource.cpp  line 1392]
	 nsBookmarksService::LoadBookmarks
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 4958]
	 nsBookmarksService::ReadBookmarks
[c:/builds/seamonkey/mozilla/xpfe/components/bookmarks/src/nsBookmarksService.cpp
 line 4789]
	 XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp 
line 102]
	 XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp  line 2025]
	 XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp 
line 1293]
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 845]
	 js_Interpret	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2812]
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
	 js_InternalInvoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 936]
	 JS_CallFunctionValue	[c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 3434]
	 nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 1043]
	 GlobalWindowImpl::RunTimeout
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 4751]
	 GlobalWindowImpl::TimerCallback
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 5107]
	 nsTimerImpl::Fire	[c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp 
line 383]
	 nsAppShell::Run	[c:/builds/seamonkey/mozilla/widget/src/windows/nsAppShell.cpp
 line 176]
	 nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480]
	 main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1289]
	 main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1639]
	 WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1660]
	 WinMainCRTStartup()
	 KERNEL32.dll + 0x2847c (0x77ea847c)
 
 	Source File : c:/builds/seamonkey/mozilla/rdf/base/src/nsRDFService.cpp line :
1025
     (17730612)	Comments: I was trying to opening Mozilla 1.3b; don't know why
the Netscape Qulaity Feedback Agent got involved.
     (17708367)	Comments: opened program
     (17642992)	Comments: Mozilla crashes at launch
     (17642698)	Comments: Mozilla crashes on launch. I even have uninstalled 
deleted the programdata catalog  run Norton Windoctor to clean up the mess and
reinstalled. Don't help
     (17573915)	URL: http://www.caplex.no
     (17573915)	Comments: Mozilla crashes when loading
     (17573876)	Comments: hitting refresh button because address would not show
up in the address bar also i could not type anything in there

*** This bug has been marked as a duplicate of 196094 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.