mozilla-bin fails to link on hp-ux

RESOLVED FIXED

Status

SeaMonkey
General
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: Jim Dunn, Assigned: Jim Dunn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

15 years ago
While trying to link on hp-ux, we run into an unsat symbol.

aCC -ext +p +DAportable +DS2.0 +W67,652,728,740,749,829 -o mozilla-bin  ...     
/usr/ccs/bin/ld: Unsatisfied symbols:
   SFRC4nsIDP11nsISupportsT1PP::nsComponentManager::CreateInstance (code)
gmake: *** [mozilla-bin] Error 1

I talked this over briefly with doug, since I am assuming it has to do
with linking with lib xpcomglue_s.a instead of against -lxpcom.
I spent some time trying to figure it out, but came up blank.

No one is really looking at this (no one is building hp-ux these days,
there are no tboxes...) but I figured I would log it.
(Assignee)

Comment 1

15 years ago
changing qa contact
QA Contact: asa → jdunn
(Assignee)

Comment 2

15 years ago
here is the LD command 

 /usr/ccs/bin/ld -o mozilla-bin /opt/langtools/lib/crt0.o -u ___exit -u main -L
/opt/aCC/lib /opt/aCC/lib/cpprt0.o -ynsComponentManager::CreateInstance
nsAppRunner.o nsWindowCreator.o showOSAlert.o nsSigHandlers.o nsStackFrameUnix.o
nsNativeAppSupportGtk.o nsNativeAppSupportBase.o -L ../../dist/bin -L
../../dist/lib ../../dist/lib/libstring_s.a
../../dist/lib/libstring_obsolete_s.a ../../dist/lib/libxpcomglue.a
../../dist/lib/libembedstring_s.a -L ../../dist/bin -lmozjs -L
/builds/jdunn/trunk/mozilla/obj/dist/lib -lplds4 -lplc4 -lnspr4 -lpthread -L
/opt/gtk+/lib -lgtk -lgdk -L /opt/glib/lib -lgmodule -lglib -L /opt/gettext/lib
-lintl +b /opt/gnome/lib -lXext -lX11 -lm -lm -lstd -lstream -lCsup -lm -lcl -lc
/usr/lib/libdld.sl >/builds/jdunn/tmp/AAAa24330 2>&1
 /opt/aCC/bin/c++filt </builds/jdunn/tmp/AAAa24330 1>&2
/usr/ccs/bin/ld: Unsatisfied symbols:
   static nsComponentManager::CreateInstance(const nsID &,nsISupports *,const
nsID &,void **) (first referenced in nsAppRunner.o) (code)

and the error output of the LD command is

/usr/ccs/bin/ld: Unsatisfied symbols:
   CreateInstance__18nsComponentManagerSFRC4nsIDP11nsISupportsT1PPv (first
referenced in nsAppRunner.o) (code)

Comment 3

15 years ago
Created attachment 118066 [details] [diff] [review]
Patch to build Mozilla 1.3 on HP-UX 11i

We used aCC 03.39 and had the same problem (and one other). The attached patch
fixed it for us to ignore the .h file bringing in the offending function. I
think it's an aCC bug as Solaris, IRIX, Tru64 UNIX, and GCC work fine.
Attachment #118066 - Flags: superreview+
Attachment #118066 - Flags: review?(kaie)
fwiw, the first part of this patch seems to be already checked in
(Assignee)

Comment 5

15 years ago
note: ignore the nsCrypto.cpp patch, that was fixed in bug 196893

The review that is important is of nsAppRunner.cpp
Comment on attachment 118066 [details] [diff] [review]
Patch to build Mozilla 1.3 on HP-UX 11i

OK, then it doesn't really matter who reviews it.

Also, the |#include "nsIURI.h"| can be removed too.
Attachment #118066 - Flags: review?(kaie) → review?

Updated

15 years ago
Attachment #118066 - Flags: review? → review+
Fix checked in to trunk, 2003-03-21 12:48 PST.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 8

15 years ago
*** Bug 198793 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.