Cursor keys behave oddly in address bar

RESOLVED WORKSFORME

Status

()

Core
Selection
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Sam Hulick, Assigned: mjudge)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030304
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030304

When pressing Alt+D (or F6) to skip to the address bar, or clicking it so it
hilights the whole URL, pressing right-arrow key then either left/right arrow
key jumps to the beginning of the URL

Reproducible: Always

Steps to Reproduce:
1. Go to any URL
2. Either hit Alt+D or click the URL so the whole line highlights
3. Press the right cursor key. the cursor will appear properly at the end of the URL
4. Press either the left or right cursor key.
Actual Results:  
Cursor jumps to beginning of URL improperly

Expected Results:  
If pressed left cursor key, it should've moved back one position.  If pressed
right cursor key, it should've remained at end of URL
selection
Assignee: asa → mjudge
Component: Browser-General → Selection
QA Contact: asa → pmac
*** Bug 196212 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
using 1.4b build 20030505 on win2k, i can no longer reproduce the problem.
reporter, could you retest this.

Comment 4

15 years ago
WFM on WinXP 2003052808

Comment 5

15 years ago
WFM:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030604

Comment 6

14 years ago
Marking WFM using 2004020909 in Win32 (WinME).

Reporter, if you are still having this problem with a more recent build, please
re-open or create a new bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.