double-clicking on a word in list or table brings up properties dialog

VERIFIED FIXED

Status

SeaMonkey
Composer
--
critical
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: John Keiser (jkeiser))

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

(Reporter)

Description

15 years ago
when i double-click on a word in list or table, it brings up properties dialog.
this should only occur if i double-click just outside of the word (compare with
bug 105984).

1. open a compose window.
2. create a list or table and type several words one a line (for a list) or
withing a table cell.
3. move mouse pointer so that it's right over a word (not on the edge, or
outside --just to be unambiguous).
4. double-click the mouse.

expected: word should become selected, and that's it.

actual results: word is selected, but the corresponding properties dialog
appears as well.

seems like a regression. will try to narrow down...
(Reporter)

Comment 1

15 years ago
looks like this regressed btwn 2/14 (works fine) and 2/15 (broken). then again,
with 2/15, that's were dbl-click selected a line instead of a word (another bug).

Comment 2

15 years ago
Related to bug 193689 ?  The odd thing is that jkeiser tested the dbl-click of
word in a list scenario (if I read that bug correctly)...

-->jkeiser
Assignee: composer → jkeiser
(Assignee)

Comment 3

15 years ago
yeah, that's extremely odd; I remember this being an issue particularly and I
remember fixing it.

Comment 4

15 years ago
Composer triage team: nsbeta1+/adt2
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt2]

Comment 5

15 years ago
*** Bug 198621 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Please make sure this gets fixed. I'm going to start using another HTML editor
till it is :-( I never knew how much I double clicked words before I ran into
this bug.

Comment 7

15 years ago
I was also doing some editing recently and this was unbearable.
Severity: normal → critical
Flags: blocking1.4a?
(Assignee)

Comment 8

15 years ago
doh!  What with all the branches and trunks and patches, I missed checking in
the second patch for bug 193689.  I'll ask for approval for that one.
Depends on: 193689
(Assignee)

Comment 9

15 years ago
Fix from that bug checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Flags: blocking1.4a?

Comment 10

15 years ago
Verified in the 2003-04-10-08 Macho and 2003-04-10-04 Win32 trunk build.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.