Remove edit>preferences>mailandnewsgroups>windows

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
--
minor
VERIFIED FIXED
15 years ago
13 years ago

People

(Reporter: Pham, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 5 obsolete attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030228
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030228

Is it really neccessary? Move "When opening new messages, display them in:"
under Message Display.

For window layout, move that to View>LayoutStyle>wide, narrow, no preview.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

15 years ago
Created attachment 116507 [details]
Redesigned layout

I think that Edit>prefs is too large. It needs as little prefs as possible.
This is AOL Communicator's layout prefs.
(Reporter)

Comment 2

15 years ago
Created attachment 116721 [details]
Preview
(Reporter)

Updated

15 years ago
Summary: No need for edit>prefs>mailandnewsgroups>windows → Remove edit>preferences>mailandnewsgroups>windows
(Reporter)

Comment 3

15 years ago
Is it really neccessary? Move "When opening new messages, display them in:"
under Message Display.

Forget that. Minotaur doesn't have that unneccessary option, so it'll probably
removed from Mozilla too.

Comment 4

15 years ago
Hopefully this will get converted to a menu option, once a couple of other bugs
get fixed.
Product: Browser → Seamonkey
(Assignee)

Comment 5

13 years ago
We will be looking at removing this pref panel but still want to keep the "When
opening new messages, display them in:" pref somewhere - TB still does have this
pref. This work will be done as part of revamp of pref panels throughout the suite.
Assignee: sspitzer → bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

13 years ago
Created attachment 180724 [details]
Proposed Pref Panel v0.1a

This is my initial stab at the pref panel, feel free to suggest changes.
(Assignee)

Updated

13 years ago
Attachment #180724 - Attachment is patch: false
Attachment #180724 - Attachment mime type: text/plain → image/png

Comment 7

13 years ago
While I agree that an entire pref page just for switching the window layout is a
waste of space, I'm not quite sure where to put that configuration option.

In recent nightlies, the option is available via View->Layout, which would be
even more useless if the reason "noone uses that option more than once" would hold.

Since I don't believe in this reason, I agree that now that View->Layout is
there the Windows panel can go. 

RIP. :)
(Assignee)

Comment 8

13 years ago
Created attachment 181451 [details] [diff] [review]
Provisional patch v0.1b

This patch:
* Rearranges view messages pref panel
* Adds new/existing window pref from windows pref panel
* Adds remote content pref from images pref panel

Still to be done:
* Check how new view messages pref panel looks on OS X and with large fonts
* Remove windows pref panel
* Remove remote content pref from images pref panel

Comment 9

13 years ago
Created attachment 181456 [details]
prefs-pane Classic/Modern on OS X

Here's how it looks on Mac OS X.
(Assignee)

Comment 10

13 years ago
Created attachment 181468 [details]
Revised Pref Panel v0.1c

Changes since last screenshot:
* Swapped groupboxes over
* Retitled Plain Text Messages groupbox to free up space
* Retitles Viewing Messages groupbox to General
Attachment #180724 - Attachment is obsolete: true
(Assignee)

Comment 11

13 years ago
Created attachment 181635 [details] [diff] [review]
Full patch (inc. help changes) v0.1c

Changes since v0.1b
* Swapped groupboxes over in message display pref pane
* Retitled Plain Text Messages groupbox to free up space in message display
pref pane
* Retitles Viewing Messages groupbox to General in message display pref pane
* Removes windows pref panel from Mail & Newsgroups section
* Removes remote content pref from images pref panel
* Adjusts help pages to match new pref locations
Attachment #181451 - Attachment is obsolete: true
Attachment #181635 - Flags: review?(mnyromyr)

Comment 12

13 years ago
Comment on attachment 181635 [details] [diff] [review]
Full patch (inc. help changes) v0.1c

Just some nits (and an error we already talked about):

>Index: mailnews/base/prefs/resources/locale/en-US/pref-viewing_messages.dtd
>===================================================================
[...]
>+<!ENTITY displayPlainText.label           "When Displaying Plain Text Messages">

All the other text is using regular case sensitivity, why not this one?

>Index: mailnews/base/prefs/resources/locale/en-US/pref-viewing_messages.dtd
>===================================================================
[...]
>+<!ENTITY reuseExp.label                   "When opening messages, display them in:">
>+<!ENTITY reuseExpRadio0.label             "A new message window">
>+<!ENTITY reuseExpRadio0.accesskey         "n">
>+<!ENTITY reuseExpRadio1.label             "An existing message window">
>+<!ENTITY reuseExpRadio1.accesskey         "e">

These entity names are pretty non-descriptive...

>Index: xpfe/components/prefwindow/resources/content/pref-help.js
>===================================================================
[...]
>   "chrome://messenger/content/addressbook/pref-addressing.xul": "nav_view",
[...]
>-  "chrome://messenger/content/addressbook/pref-addressing.xul": "mail_prefs_addressing",

Wrong element killed.

>Index: extensions/help/resources/locale/en-US/mail_help.xhtml
>===================================================================
[...]
>+<p>To change which columns are displayed, begin from the Mail window:</p>

I'm not a native English speaker, but the second half of this sentence sounds
quite odd to me.

>+  <li>Click the Show/Hide Columns icon <img src="images/columns.png" alt=""/>

That thingy is known as the "columnpicker".

>+<p>By default, you can view remote images and other remote content in the
>+  mail messages you receive.

How About:
"By default, remote images and other remote content is displayed in messages
you receive."
(It's not just mails.)


Feel free to ignore my English language nits as completely unqualified. ;-)
Attachment #181635 - Flags: review?(mnyromyr) → review-
(Assignee)

Comment 13

13 years ago
Created attachment 181916 [details] [diff] [review]
Tweaked patch v0.1d

Changes since v0.1c
* Use regular case sensitivity for groupbox title
* Gave some entities more descriptive names
* Killed correct element
* Changed remote images line in help

"begin from the Mail window" is the style used throughout this help file, so
keeping with that for the moment.

"columnpicker" is not used anywhere else in the help files, always refered to
as  "the Show/Hide Columns icon", so again keeping with that for the moment.
Attachment #181635 - Attachment is obsolete: true
Attachment #181916 - Flags: review?(mnyromyr)

Updated

13 years ago
Attachment #181916 - Flags: review?(mnyromyr) → review+
(Assignee)

Updated

13 years ago
Attachment #181916 - Flags: superreview?(neil.parkwaycc.co.uk)
(Assignee)

Updated

13 years ago
Attachment #181916 - Flags: superreview?(neil.parkwaycc.co.uk)
(Assignee)

Comment 14

13 years ago
Created attachment 182071 [details] [diff] [review]
Nits fixed patch v0.1e (Checked in)

Changes since v0.1d (as requested by Neil)
* Removed overlay information of mailPrefsOverlay.xul for pref-images.xul from
contents.rdf
* Renamed id for radiogroup for mailnews.reuse_message_window to tie in with
pref name
* Moved fixed/variable font pref to top of its groupbox
* Changed description from "In quoted messages:" to "Settings for quoted
messages:"
* Removed typo I'd introduced to mail_help.xhtml

Carrying forward r= from Mnyromyr and Neil, requesting sr
Attachment #181916 - Attachment is obsolete: true
Attachment #182071 - Flags: superreview?(bienvenu)
Attachment #182071 - Flags: review+
(Assignee)

Comment 15

13 years ago
Created attachment 182072 [details]
Screenshot of panel from v0.1e
Attachment #181468 - Attachment is obsolete: true

Comment 16

13 years ago
Comment on attachment 182071 [details] [diff] [review]
Nits fixed patch v0.1e (Checked in)

I also think "Begin from" is awkward. Perhaps just "From the mail window" or
"In the mail window..." though neither of those seem quite right either.
Attachment #182071 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Updated

13 years ago
Blocks: 292235
(Assignee)

Comment 17

13 years ago
Comment on attachment 182071 [details] [diff] [review]
Nits fixed patch v0.1e (Checked in)

Requesting approval for appsuite only, fairly low risk patch.

Spun off existing help awkwardness to bug 292235.
Attachment #182071 - Flags: approval1.8b2?

Comment 18

13 years ago
Comment on attachment 182071 [details] [diff] [review]
Nits fixed patch v0.1e (Checked in)

a=asa
Attachment #182071 - Flags: approval1.8b2? → approval1.8b2+
(Assignee)

Comment 19

13 years ago
Comment on attachment 182071 [details] [diff] [review]
Nits fixed patch v0.1e (Checked in)

Checking in mailnews/jar.mn;132 characters written
/cvsroot/mozilla/mailnews/jar.mn,v  <--  jar.mn
new revision: 1.94; previous revision: 1.93
done
Checking in mailnews/base/resources/content/contents.rdf;
/cvsroot/mozilla/mailnews/base/resources/content/contents.rdf,v  <-- 
contents.rdf
new revision: 1.39; previous revision: 1.38
done
Checking in mailnews/base/prefs/resources/content/mailPrefsOverlay.xul;
/cvsroot/mozilla/mailnews/base/prefs/resources/content/mailPrefsOverlay.xul,v 
<--  mailPrefsOverlay.xul
new revision: 1.27; previous revision: 1.26
done
Checking in mailnews/base/prefs/resources/content/pref-viewing_messages.xul;
/cvsroot/mozilla/mailnews/base/prefs/resources/content/pref-viewing_messages.xu
l,v  <--  pref-viewing_messages.xul
new revision: 1.47; previous revision: 1.46
done
Checking in mailnews/base/prefs/resources/locale/en-US/mailPrefsOverlay.dtd;
/cvsroot/mozilla/mailnews/base/prefs/resources/locale/en-US/mailPrefsOverlay.dt
d,v  <--  mailPrefsOverlay.dtd
new revision: 1.20; previous revision: 1.19
done
Checking in
mailnews/base/prefs/resources/locale/en-US/pref-viewing_messages.dtd;
/cvsroot/mozilla/mailnews/base/prefs/resources/locale/en-US/pref-viewing_messag
es.dtd,v  <--  pref-viewing_messages.dtd
new revision: 1.22; previous revision: 1.21
done
Checking in xpfe/components/prefwindow/resources/content/pref-images.xul;
/cvsroot/mozilla/xpfe/components/prefwindow/resources/content/pref-images.xul,v
 <--  pref-images.xul
new revision: 1.13; previous revision: 1.12
done
Checking in xpfe/components/prefwindow/resources/content/pref-help.js;
/cvsroot/mozilla/xpfe/components/prefwindow/resources/content/pref-help.js,v 
<--  pref-help.js
new revision: 1.21; previous revision: 1.20
done
Checking in extensions/help/resources/locale/en-US/help-toc.rdf;
/cvsroot/mozilla/extensions/help/resources/locale/en-US/help-toc.rdf,v	<-- 
help-toc.rdf
new revision: 1.77; previous revision: 1.76
done
Checking in extensions/help/resources/locale/en-US/mail_help.xhtml;
/cvsroot/mozilla/extensions/help/resources/locale/en-US/mail_help.xhtml,v  <-- 
mail_help.xhtml
new revision: 1.59; previous revision: 1.58
done
Checking in extensions/help/resources/locale/en-US/privacy_help.xhtml;
/cvsroot/mozilla/extensions/help/resources/locale/en-US/privacy_help.xhtml,v 
<--  privacy_help.xhtml
new revision: 1.42; previous revision: 1.41
done
Checking in extensions/help/resources/locale/en-US/using_priv_help.xhtml;
/cvsroot/mozilla/extensions/help/resources/locale/en-US/using_priv_help.xhtml,v
 <--  using_priv_help.xhtml
new revision: 1.56; previous revision: 1.55
done
Attachment #182071 - Attachment description: Nits fixed patch v0.1e → Nits fixed patch v0.1e (Checked in)
(Assignee)

Comment 20

13 years ago
Removing content/pref-windows.xul;
/cvsroot/mozilla/mailnews/base/prefs/resources/content/pref-windows.xul,v  <-- 
pref-windows.xul
new revision: delete; previous revision: 1.5
done
Removing locale/en-US/pref-windows.dtd;
/cvsroot/mozilla/mailnews/base/prefs/resources/locale/en-US/pref-windows.dtd,v 
<--  pref-windows.dtd
new revision: delete; previous revision: 1.6
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Blocks: 292278
QA Contact: esther → technutz
Verified FIXED in 2005-05-05-06: the Edit -> Preferences -> Mail and Newsgroups
-> Windows preference is gone, and has been successfully replaced by the Layout
menu.

Windows XP, Seamonkey trunk.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.