Xlib not redrawing/repainting until input activity

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
16 years ago
2 months ago

People

(Reporter: kmic5, Assigned: roland.mainz)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021212
Build Identifier: 

If a document is graphically changed through a DOM call after it has been
loaded, the xlib event loop does not process the redraw to show the effects of
the change until input activity (i.e. mouse hover) happens on the window it
monitors.

This bug has been verified by Ginsburn.

Reproducible: Always

Steps to Reproduce:
Load any webpage that uses the DOM to graphically change an element after the
webpage is completely loaded.

Example: Set the innerHTML of a <div> to reflect the current time every second.
Actual Results:  
The redraw/repaint is not performed until the window gets input/mouse activity.

Expected Results:  
Redraw should take place immediately after DOM modification.
.
Assignee: roc+moz → Roland.Mainz
Component: Layout: View Rendering → GFX: Xlib
QA Contact: ian → timeless
(Assignee)

Comment 2

16 years ago
s/Ginsburn/Gisburn/
(Assignee)

Comment 3

16 years ago
I remember that I fixed that bug - but it seems the nsITimer changes made a
while ago foobar'ed the fix... ;-(
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

16 years ago
kmic5@hotmail.com:
Can you provide a small testcase, please ?
(Reporter)

Comment 5

16 years ago
The User-Agent listed in the original bug report should be ignored. It does not
pertain to this bug. Also, Ginsburn = Gisburn.

Here is a testcase:
http://www.ocsoft.net/mozbug196278.htm

On a build experiencing the bug, you will only see the time updated when the
window gets mouse activity. It should be updating every second. You must be
using an xlib-only build of Mozilla to see the bug.
Component: GFX: Xlib → Layout: View Rendering

Comment 6

14 years ago
Created attachment 169714 [details]
testcase similar to the one described in comment #5

The link in comment #5 seems to be broken. I could reproduce this bug with a
recent xlib firefox build on FreeBSD 5.3. You can also press a key instead of
moving the mouse in order to refresh the window.

Updated

14 years ago
Keywords: testcase
(Reporter)

Comment 7

14 years ago
(In reply to comment #5)
> The User-Agent listed in the original bug report should be ignored. It does not
> pertain to this bug. Also, Ginsburn = Gisburn.
> 
> Here is a testcase:
> http://www.ocsoft.net/mozbug196278.htm
> 
> On a build experiencing the bug, you will only see the time updated when the
> window gets mouse activity. It should be updating every second. You must be
> using an xlib-only build of Mozilla to see the bug.

(In reply to comment #6)
> Created an attachment (id=169714) [edit]
> testcase similar to the one described in comment #5
> 
> The link in comment #5 seems to be broken. I could reproduce this bug with a
> recent xlib firefox build on FreeBSD 5.3. You can also press a key instead of
> moving the mouse in order to refresh the window.

The testcase (from comment #5) has been moved to:
http://www.ocsoft.net/moz/mozbug196278.htm

Comment 8

12 years ago
Xlib port has been removed from trunk (bug 326152)

-> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Component: Layout: View Rendering → Layout: Web Painting
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.