The spelling box or an alert box does not popup blocking the window.

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
major
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Yves Lambert, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b; MultiZilla v1.3.1 (h)) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b; MultiZilla v1.3.1 (h)) Gecko/20030210

Using the correction tool sometimes (rarely) the spelling tool box does not
popup. There is no way to close the mail window. e-mail is not sent
A confirmation box could not popup in mails and newsgroup too blocking the mail
window.

Reproducible: Sometimes

Steps to Reproduce:
1. strike "send" while automatic spellchecking is on
or
2. strike next message when all messages are read in the folder
3.

Actual Results:  
the box is not popped up and the current window is hanged.

Expected Results:  
popup the spelling tool box box or confirm.

Each time it happenned i had to kill Mozilla process to retrieve full control

attaching windows report this time. I wonder if there is a way to provoke a
crash to get Mozilla full circle information instead..
(Reporter)

Comment 1

16 years ago
Attempting to change to browser/XUL but i get blocked with either a bugzilla bug
or a javascript bug of mozilla: cannot change component :(
This happen to browser too: 
I have 2 windows blocked now :(
Component: Composition → Browser-General
Product: MailNews → Browser

Comment 2

16 years ago
Yves, is this problem occuring in the mailnews client or the browser?

Also, does this problem occur if MultiZilla is uninstalled?
Severity: critical → major
(Reporter)

Comment 3

16 years ago
Chris: it occurs on both. that's why i changed the product to browser/browser
general. I first put "mail"
when a composing mail windows is blocked by an undisplayed confirmation box or
spellchecker box, i can't exit mozilla. 
when it's either a browser window or a a mail/news window, i can exit without
any problem.
I did  not check it without multizilla, and as it happens only sporadically i
won't be able to say if it does or not.
Question: is 1.40 the same braunch? i'd rather install a nightly build and try
if it occurs again with and without multizilla. 
** XP does not let me kill the process softly: so i can't get a Dr Watson report
: is there a way to generate a full circle report ? 

Comment 4

16 years ago
Yves,

The pre-1.4 builds are the trunk, whereas the 1.3x builds are in their own
branch.  Try it out with the pre-1.4 without Mozilla, and we'll try to narrow
down where the problem is.

Generating talkback data is only useful with a crash bug, so I don't think it
would help much here.
(Reporter)

Comment 5

16 years ago
Checking with a trunk build without multizilla. 

I think that the Xtra Problem  when it occurs with a compose mail window is
proper to M$ window
(Reporter)

Comment 6

16 years ago
It did not occur with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a;
without MultiZilla and SpellChecker. I am going to try with both and if i get
the bug with MZ and not  SpellChecker, and last with SpellChecker and not MultiZilla


It looks like some other alert box bugs some may be reopened and targetted with
1.3 braunch (this may depend on them) if i can't reproduce the bug with 1.4 in
any way, i'll check dependancies (and dupes) with 1.3b

Comment 7

16 years ago
I wonder if you see JS errors on the JS console. Also, I'm unable to reproduce
this with MS Windows NT/XP Pro.

Comment 8

15 years ago
1.3.1 is ancient as far as bug reports are concerned. If this still occurs in
recent builds, and without MultiZilla or other extensions installed, please feel
free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 9

15 years ago
"when a composing mail windows is blocked by an undisplayed confirmation box or
spellchecker box, i can't exit mozilla. 
when it's either a browser window or a a mail/news window, i can exit without
any problem."

This is a mozilla z-order problem. This has nothing to do with MultiZilla.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.