chat site says Java is not enabled after logging in as unregistered guest, even though all Java and JavaScript are enabled in Mozilla advanced preferences.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: ancientone, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

I go to site www.spinchat.com. I log in as an unregistered ( "guest ) chat user.
 Clicking on "go" or pressing ENTER yield an error page from the site server
indicating THEY think Mozilla's Java and JavaScript are not enabled.  However,
checking Mozilla preferences under the Advanced tab shows Java is enabled for
the browser and mail and newsgroups, and JavaScript is checked for all boxes. 
IE 6.0 runs this site OK, no problems.

Reproducible: Always

Steps to Reproduce:
1. Go to the site www.spinchat.com
2. In the center (non-sidebar) log-in area, enter a chatter name (nickname),
check the box by "Note: By entering the chat you agree to our Terms of Use,"
then click "Go" or press ENTER.
3. You should receive an error page / display indicating Java is not enabled.
4. Choosing to click "continue" takes you to the normal pages, then select "Chat
Rooms" from the sidebar display on the left of the screen.  You are taken to a
list of chat rooms.
5. Choose a chat room name from the list and click on it.  Nothing happens.

Actual Results:  
The display did not change, "Done" was displayed in the Mozilla status area.

Expected Results:  
Mozilla should function as IE or Netscape do, taking the user to the chatroom.

Please advise if you think this is a Java coding problem site's coding for Java
detection and usage.

Thanks!
(Reporter)

Comment 1

16 years ago
Created attachment 116608 [details]
screenshot of Mozilla encountering Java not enabled message from website

Comment 2

16 years ago
The site works for me, with Moz 1.3b on WinXP.  Do other Java applets work for
you?  Please try with Mozilla 1.3b or newer.
(Reporter)

Comment 3

16 years ago
1.3b *initially* yielded the same results, but ... DUH!!  I didn't think to
check for JRE installed (it wasn't).  Installed Sun J 2 JRE (1.3.1_07).  All is
well.  No bug, other than Mozilla documentation should clearly inform users to
be sure JRE is installed when using Java; the more Java resources available, the
less likely this kind of problem will happen.  IE apparently uses its own
internal Java VM (or whatever Microsoft makes available).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.