IFRAME turns black after switching to another tab, then closing it.

RESOLVED DUPLICATE of bug 196308

Status

--
minor
RESOLVED DUPLICATE of bug 196308
16 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: jag-mozilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030307
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a) Gecko/20030307

On a page with an IFRAME, switching to another tab and then closing that tab and
returning to the page with the IFRAME causes the IFRAME itself to turn
completely black. This also happens if you create a new tab in the background,
then middle-click on it to close it without ever leaving the page with the IFRAME.

Scrolling down to hide the frame, then scrolling back up to cause a repaint
seems to fix the problem. I first noticed this with the IFRAME at
http://bugzilla.mozilla.org/enter_bug.cgi

Reproducible: Always

Steps to Reproduce:
1. Open a page containing an IFRAME, such as
http://bugzilla.mozilla.org/enter_bug.cgi
2. Press CTRL-T to create a new tab.
3. Close the new tab and return to the page with the IFRAME.

Actual Results:  
The IFRAME was completely black.

Expected Results:  
The IFRAME should have been repainted with the actual contents of the frame.
should be a dupe of bug 196308 (another effect from the same bug)

Comment 2

16 years ago

*** This bug has been marked as a duplicate of 196308 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.