When forwarding more than one message as an attachment, the first message on the list is duplicated for all others.

VERIFIED WORKSFORME

Status

MailNews Core
Attachments
--
critical
VERIFIED WORKSFORME
15 years ago
10 years ago

People

(Reporter: Rauhnee Ranshanka, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2.1) Gecko/20021130

When forwarding more than one message as an attachment, all of the messages are
replaced by the first forewarded message.  This includes text, attachments,
number of attachments -- everything.  It saves as if I had attached the same
message the number of times equil to the number of messages forwarded.

Reproducible: Always

Steps to Reproduce:
1. Have the forwarding preferance set to 'as attachment'.
2. Highlight more than message. It does not matter if it has an attachment or not.
3. Forward it (it should all be attached in a single message).
4. Save it.
5. Look at the saved message. All of the messages will be copies of the first one.

Actual Results:  
The message has the correct number of attachments, but they are all duplicates
of the first message.

Expected Results:  
All of the messages forwarded should have been there.

This occures with several themes, including the default one.  I have
uninstalled, cleaned all residual Mozilla data and installed it, and it still
occures.
[Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.4a) Gecko/20030401]

WorksForMe (v1.4a/W95).
I forwarded 2 plain text messages without attachements;
Then I saved to file(s) both the sent and the received emails: both correct.

Reporter, can you check with a recent build.

Comment 2

15 years ago
Rauhnee Ranshanka, please confirm whether this bug is still a problem for you 
with a current version of Mozilla, at least 1.4 Final.
Thanks for the reminder ;->

Going a step further, since there was no reply since 2003-04-27 (6+ months):
*Changing: (St) Unconfirmed -> WorksForMe, based on comment 1.
*Reporter: Please check with v1.4.1 or v1.5(+), comment on the result, and
reopen as needed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.