Startup script /opt/gnome/bin/mozilla contains errors when using Java Plugin

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
16 years ago
14 years ago

People

(Reporter: richard.cross, Assigned: blizzard)

Tracking

Trunk
Sun
SunOS

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020918
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0.1) Gecko/20020918

2 errors in the startup script /opt/gnome/bin/mozilla that only become apparent
when the JRE plugin that comes with Java 1.4.0_03 is linked from the Mozilla
plugin directory:

1.  On lines 98, 203 & 208, the expression 'grep -e' will not work because '-e'
is an invalid switch in /usr/bin/grep (although it is valid in
/usr/xpg4/bin/grep).  The script either needs to source in a new PATH that has
"/usr/xpg4/bin" at the beginning, or grep should be called as "/usr/xpg4/bin/grep".

2.  In line 118, the expression "export LD_ASSUME_KERNEL=2.2.5" (which is a
concatenation of "LD_ASSUME_KERNEL=2.2.5; export LD_ASSUME_KERNEL") is invalid
in the Bourne Shell - either the script header should be changed to
#!/usr/bin/ksh" or (preferably)  the full un-concatenated version should be used.



Reproducible: Always

Steps to Reproduce:
1.  Install Java 1.4.0_03
2.  ln -s /usr/local/j2sdk1.4.0_03/jre/plugin/sparc/ns610/libjavaplugin_oji.so
/opt/gnome/lib/mozilla-1.0.1/plugins/libjavaplugin_oji.so
3.  /opt/gnome/bin/mozilla


Actual Results:  
The script produced standard shell errors that were easy to diagnose, however
once these errors were fixed, Mozilla still failed to run.  A stack trace
(attached) shows why



Expected Results:  
Launched the Mozilla browser, presumably.

This is the version of Mozilla that comes with Ximian Gnome desktop for Solaris
8 Sparc Edition.
(Reporter)

Comment 1

16 years ago
Have managed to get Mozilla to start with the JRE plugin (from Java  1.4.0_03)
by creating a ~/.mozilla/plugins directory and linking
/usr/local/j2sdk1.4.0_03/jre/plugin/sparc/ns600/libjavaplugin_oji.so (N.B. the
ns600 version) to it.  

I'm not sure whether it was the fact that I put it in the local user's plugins
directory or whether it was because I used the ns600 version rather than the
ns610 version.  However, the Bourne Shell launch script still has (easy to fix)
errors in it (see above), so I'll leave it up to you guys as to what status to
assign.
cls, do you do startup script stuff?  I can't recall.

The two java plugins (600 and 610) are compiled with different compilers; which
one works with your Mozilla depends on the compiler the Mozilla was compiled with.

Comment 3

16 years ago
I'm trying to avoid it as much as possible nowadays.  The stock mozilla startup
script doesn't have the extra java checks so Ximian must be using the modified
script blizzard uses in his rpms.
Assignee: asa → blizzard
(Reporter)

Comment 4

16 years ago
So should I be submitting this bug (and my working script) to Ximian instead?
(Assignee)

Comment 5

16 years ago
Yeah, sorry, please report that to Ximian.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.