Closed Bug 196696 Opened 17 years ago Closed 17 years ago

Sort by Flag then Date, shows flags at undesired end of list

Categories

(SeaMonkey :: MailNews: Message Display, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 57898

People

(Reporter: bugzilla, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a; MultiZilla v1.3.1 (a); Eg e Viking eg) Gecko/20030305
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4a; MultiZilla v1.3.1 (a); Eg e Viking eg) Gecko/20030305

I use flags in the mail client to mark emails I need to remember to act upon. I
dont tend to use labels and priority, as flagging something is quicker.

However my prefered view of having flagged messages first, then the rest sorted
by date descending is not possible. The date sort is always defaulted to
ascending, meaning the emails i am most interested is right at the top and right
at the bottom, whether I view it ascending or descending.

My other prefered view which is also not possible, would be the same in threaded
mode with either watched threads or flags at the top, but that could be another
bug report for another day.

Bug 20385 & Bug 72493 deals with date sort issues woth threads, but not a
duplicate of this request as I believe threading to be a different ketle of fish.

The newish view filters, dont have an option for flags, although I expect it
could be custumized, but no sorting is available.

I suppose this could be part of a broader sort selection options, eg sort by
flag then priority then date. Which is why I thought this must have been
reported before, but I couldnt find any previous bugs with any combination of
"sort,order,flag,date,mail,column".

Also is this a bug or enhancement? it is not behaving as it should, although
some weirdos might prefer it the way it currently is. I am filing it as a bug,
but if someone got a good case for it to be an enhancement then it is fine by me.

Reproducible: Always

Steps to Reproduce:
1.press date column
2.press flag column
3.press flag column(optional)

Actual Results:  
sorted by either flags at the top and newest mail at bottom or other way round.

Expected Results:  
sorted by flags at the top followed by newest mails and oldest at the borrom.
Multiple criterion sort is Bug 57898.  This appears to be a duplicate.

*** This bug has been marked as a duplicate of 57898 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
I would argue that the OP's expected results (that flagged messages sort near
newer rather than older unflagged messages) should be the default behavior of
sorting by flag and should not require sorting by multiple criteria, and as such
deserves to be its own bug/RFE rather than be considered a duplicate of the
"multiple sort" bug.
*** Bug 238631 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.