document.all has no properities

RESOLVED DUPLICATE of bug 174994

Status

Tech Evangelism Graveyard
Hebrew
RESOLVED DUPLICATE of bug 174994
16 years ago
3 years ago

People

(Reporter: Ilia, Assigned: Katsuhiko Momoi)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

In the page mentioned the drop-down selection boxes aren't work (greyed out, no
reaction on mouse).
The JavaScript console shows "Error: document.all has no properties"
in various places of the page' JavaScript code.

In IE 6.0 it works fine.

Reproducible: Always

Steps to Reproduce:
1.Load the URL (w/JavaConsole opened to see the errors)

Actual Results:  
Drop-down selection boxes are greyed out and doesn't react on mouse events: 
either  

Expected Results:  
Display working drop-down selection boxes (that are react on mouse clicks.

Note:
The page is in Hebrew, so don't be surprised if You see gibberish instead of
text. The selection boxes behavior, however is visible anyway.

--------------- JavaScript console log: ---------------------------------
Error: document.all has no properties
Source File: http://www.ynetcenter.co.il/Header.htm Line: 255

Error: document.all has no properties
Source File: http://www.ynetcenter.co.il/SearchIn.asp?Z=C&TZ=MhValue Line: 1117

Error: document.all has no properties
Source File: http://www.ynetcenter.co.il/Bottom_Bar.htm Line: 78

Error: document.all has no properties
Source File: http://www.ynetcenter.co.il/Bottom_Bar.htm Line: 127

Error: document.all has no properties
Source File: http://www.ynetcenter.co.il/BE/content/js/functions.js Line: 70

Comment 1

16 years ago
document.all is propietary to IE... sites should be using
document.getElementById or other standard method to access elements. See:
http://devedge.netscape.com/viewsource/2001/updating-dhtml-web-pages/

Ilia, do you have any affiliation with the site, or are you just a visitor?

Confirming Evangelism
Assignee: anthonyd → momoi
Status: UNCONFIRMED → NEW
Component: DOM Traversal-Range → Middle Eastern
Ever confirmed: true
OS: Windows XP → All
Product: Browser → Tech Evangelism
QA Contact: desale → xslf
Hardware: PC → All
Version: Trunk → unspecified
(Reporter)

Comment 2

16 years ago
By request from Chris Casciano [moz@placenamehere.com]
I repost my answer to him here:

Sorry, no affiliation with this site.

B.T.W. the domains http://www.ynetcenter.co.il/ and http://www.ynet.co.il are
belong to the biggest Israeli newspaper, and the relevant websites are quite big
and content-rich.
So It looks, You will meet a professional at their webmaster position.

Unfortunately, the Israeli Internet is nearly 100% IE-based because it was the
only browser with at least a half-decent Hebrew support for years. 
Now Mozilla has a good Hebrew support, but the "world is IE only" mindset is
still here.

Best regards
	Ilia.  

Comment 3

16 years ago
>So It looks, You will meet a professional at their webmaster position

Yes? Any more info on the meeting? 

*** This bug has been marked as a duplicate of 174994 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

15 years ago
tech evang june 2003 reorg
Component: Middle Eastern → Hebrew
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.