Ever since 1.4b unable to load newer builds. Always crashes after install with the following:

RESOLVED DUPLICATE of bug 207978

Status

()

Core
XPCOM
--
critical
RESOLVED DUPLICATE of bug 207978
15 years ago
15 years ago

People

(Reporter: John Wells, Assigned: dougt)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: TB17933387X, TB17933363Y)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030304
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4a) Gecko/20030304

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:61e1aa6f.
Registers:
EAX=6552736e CS=0167 EIP=61e1aa6f EFLGS=00010202
EBX=00000000 SS=016f ESP=0065f5d0 EBP=0065f5f4
ECX=00785304 DS=016f ESI=61e1eba0 FS=4137
EDX=317b0fff ES=016f EDI=00789290 GS=0000
Bytes at CS:EIP:
8b 00 3b c3 74 21 33 f6 80 38 00 74 1a 8b 4d 08 
Stack dump:
00000000 80000000 00786d70 61e1eba0 007852e0 00000000 00000001 007852e8 00000000
0065fa48 61dfe00b 00786d74 007852e0 007894e0 00789e30 61e211c0 

Reproducible: Always

Steps to Reproduce:
1.Install latest build
2.On opening program the following error:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:61e1aa6f.
Registers:
EAX=6552736e CS=0167 EIP=61e1aa6f EFLGS=00010202
EBX=00000000 SS=016f ESP=0065f5d0 EBP=0065f5f4
ECX=00785304 DS=016f ESI=61e1eba0 FS=4137
EDX=317b0fff ES=016f EDI=00789290 GS=0000
Bytes at CS:EIP:
8b 00 3b c3 74 21 33 f6 80 38 00 74 1a 8b 4d 08 
Stack dump:
00000000 80000000 00786d70 61e1eba0 007852e0 00000000 00000001 007852e8 00000000
0065fa48 61dfe00b 00786d74 007852e0 007894e0 00789e30 61e211c0 
3.

Actual Results:  
crashed

Expected Results:  
Opened Mozilla.

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 0167:61e1aa6f.
Registers:
EAX=6552736e CS=0167 EIP=61e1aa6f EFLGS=00010202
EBX=00000000 SS=016f ESP=0065f5d0 EBP=0065f5f4
ECX=00785304 DS=016f ESI=61e1eba0 FS=4137
EDX=317b0fff ES=016f EDI=00789290 GS=0000
Bytes at CS:EIP:
8b 00 3b c3 74 21 33 f6 80 38 00 74 1a 8b 4d 08 
Stack dump:
00000000 80000000 00786d70 61e1eba0 007852e0 00000000 00000001 007852e8 00000000
0065fa48 61dfe00b 00786d74 007852e0 007894e0 00789e30 61e211c0

Comment 1

15 years ago
Did you install mozilla into a clean (empty) directory?
Does using a new profile work?

Comment 2

15 years ago
I also have problems with builds starting 20030307, after selecting profile the
browser crashed.
Keywords: crash

Comment 3

15 years ago
I tested 2003031008/trunk/W2K, browser crashed with my profile (-> TB17933387X,
TB17933363Y), with simplier profile of my girlfriend it doesn't crash. My
profile is working fine with 20030306 build.

Comment 4

15 years ago
Over to XPCOM.
Assignee: asa → dougt
Component: Browser-General → XPCOM
Keywords: stackwanted
QA Contact: asa → scc
Summary: Ever since 1.4b unable to load newer builds. Always crashes after install with the following: → Ever since 1.4b unable to load newer builds. Always crashes after install with the following:
Whiteboard: TB17933387X, TB17933363Y

Comment 5

15 years ago
*** Bug 196620 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
are you setting any of the XUL prefs mentioned in bug 196337, bug 196477 or bug
196446
Is the summary supposed to say 1.3b?

Comment 8

15 years ago
my experience with this problem began after the version started reporting '1.4'.
 All 1.3b nightly builds, and the release 1.3b, work great.

I am experiencing the same crash-on-install, and I do not have 'XUL directories'
checked.  'Disable XUL cache' appears to have no effect, whether checked or not.
 I tried both.

Comment 9

15 years ago
I had the same thing and I immediately assumed it was the binary compatibility
between version so I uninstalled and then ran the old and reliable Microsoft
RegClean tool (see link below) and it cleaned up my registry.  Reinstalled and
all is well.

Use at your own risk:
http://www.mrtech.com/toolbox/regcln41.exe

Comment 10

15 years ago
I don't think regclean would make any difference.
I'd say it's the uninstall that does it

Comment 11

15 years ago
sry to say but i had tried that, only worked after regclean.

Comment 12

15 years ago
I also see this problem: A complex profile crashes, simpler ones work.

Just to makes the builds IDs clear:

* 1.3rc works well
* trunk builds 20030307 and 20030310 crash.

Does anybody experience a crash with other builds? Only few people mentioned
their build IDs.
In case it was not clear, please do not comment on the reproducibility or steps
to reproduce of this bug unless your name is John Wells or you can prove that
you are in fact seeing this exact problem with the same exact stacks as the
original report (if you can do that, I'll be very impressed, btw, given the lack
of stacks).

Comment 14

15 years ago
I also noticed same problem. So, I didn't upgrade it until the RC1 version.
However, the 1.4 RC1 version also has same problem.

However there is a workaround for this problem. Try remove files of older mozilla.
For example, on Windows XP, under Document and Settings folder, you can find
mozilla files.

Problem is that you may lose address book and email.
You will not lose your boomarks files, if you don't remove it.
However, it is very easy to lose address book and email because it's not
apparent what to leave and what to remove.

I think there should be some procedure or tools for converting the old files to
the 1.4 versions.

Comment 15

15 years ago
Just to add my $.02..

I have been using 1.4b and I just installed RC-1.. It crashes after the install 
too (I can not even go back to 1.4b)..

That super neat-o Windows feedback agent reports this:

AppName: mozilla.exe	 AppVer: 1.4.20030.52908	 ModName: xpcom.dll
ModVer: 1.4.20030.52908	 Offset: 00040769 

I will now try some of the advice in this ticket..

Comment 16

15 years ago
Please ignore my last comment.. I posted it to the wrong bug number.. 

Comment 17

15 years ago
this may be related to bug 207978

Comment 18

15 years ago
Marking as duplicate of bug 207978

*** This bug has been marked as a duplicate of 207978 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.