Headers should use the Content-type: charset= to display message subject

VERIFIED DUPLICATE of bug 90584

Status

MailNews Core
Internationalization
VERIFIED DUPLICATE of bug 90584
15 years ago
9 years ago

People

(Reporter: Eugene Savitsky, Assigned: smontagu)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
For example in a folder we have messages in Russian (KOI8-R and Win-1251), in
English and in Estonian (ISO-8859-1). Mozilla ignores the Content-type: charset=
and displays the subhect and from fields like it is set in the folder
preferences, so we have +/-50% unreadable subject and names in russian,
corrupted subjects in estonian.

Moz 2003030504

Comment 1

15 years ago
Eugene, i am using 2003031008 build and i don't see this problem: all mime
encoded headers are displaying correctly. If it is still a problem for you,
could you please attach a problematic message? Thanks.
(Reporter)

Comment 2

15 years ago
Created attachment 116783 [details]
This is a message with converted subject and name. The body is OK.

This is a message with converted subject and name. The body is OK.

Comment 3

15 years ago
Eugene, somehow i am not able to view your attachment in Local folders, it is
open as empty.

Comment 4

15 years ago
same problem happens to me after i save the message into Local Folders.
(Reporter)

Comment 5

15 years ago
Downloaded my attach at home and I'm able to see the message competely (I use at
home The Bat! (www.ritlabs.com)), so I believe it's another problem... 
(Reporter)

Comment 6

15 years ago
Just open it in some text editor... All is there inside.

Comment 7

15 years ago
if you can try to create the attachment one more time and attach the message in
the .eml format, then we can take another look. 
(Reporter)

Comment 8

15 years ago
Marina (very nice name, I like it...), I do not see any reason why I should
attach already attacheds file? I opened same file in The Bat! and now in Outlook
Express - all is shown perfectly (I'm at home on totally differnt machine, so I
do not have the file here). The attach is fully functional and it also works
fine when opened in Mozilla's browsing window....

Or I do not get the reason to attach it again...???

Comment 9

15 years ago
well... the reason is that we need to see your message in the mail thread not in
the browser window. To do so i have to save your attachment into my Local folder
and then view the message. When i am trying to save your attachment from the
link in the bug report into the Local folder and open it: there is no message in
the folder, it is empty. It seems that there was an error while attaching since
Xianglan can not see it either. 
(Reporter)

Comment 10

15 years ago
Maybe it is another bug? How'd you explaine it opens in other mail clients? I
believe there should be some uncompatible format of the file if it was not
correctly attached? 

Anyway I'll attach it tomorrow (it's 2:02 in the night at here).

Comment 11

15 years ago

*** This bug has been marked as a duplicate of 90584 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

15 years ago
ok
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.