File open/save dialog boxes are ignorant about XPI type ...

RESOLVED DUPLICATE of bug 139214

Status

--
enhancement
RESOLVED DUPLICATE of bug 139214
16 years ago
14 years ago

People

(Reporter: Martijn.Ras, Assigned: jag-mozilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Heya Folks,

An entry for XPI ("XPI files (*.xpi)") files ought to be added to the list of
file types available in the file open/save dialog boxes.

Mazzel,

Martijn.

Comment 1

16 years ago
severity -> enhancement
Severity: normal → enhancement
Why?  Opening such files is surely more rare than opening, say, PDF files.... 
Should we really list every single possible file type in there?  Or just the
common ones?
(Reporter)

Comment 3

16 years ago
Heya Folks,

We shouldn't list every single file type, just the ones that are more or less
'native' to the component, both XPI and XUL in case of the navigator.

On the other hand we might consider enabling configuration of this in the
preferences so one has the freedom to pick which type of files one opens regularly.

Mazzel,

Martijn.

Comment 4

16 years ago
yeah, let's have more preferences!
XPI is no more native to Mozilla than PDF is, as I said....  And I'd think
anyone who's not a Mozilla tester/developer would open an XPI approximately once
in a blue moon.

Over to the rigth component.
Assignee: asa → jaggernaut
Component: Browser-General → XP Apps
QA Contact: asa → paw

Comment 6

15 years ago

*** This bug has been marked as a duplicate of 139214 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.