Reply address should be account the mail came in to, not the primary account

VERIFIED DUPLICATE of bug 187578

Status

VERIFIED DUPLICATE of bug 187578
16 years ago
10 years ago

People

(Reporter: melfinadev, Assigned: bugzilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210

I have two mail accounts set up, with filters on both that move messages into my
Local Folders.  If I reply to a message that's not from my primary account, the
message by default will get sent from my primary account, when it should be sent
from the accont that the email came in on.  This way, if I'm replying to someone
on my work account, I don't have to manually switch the reply-to address to be
my work account instead of my primary account.

Reproducible: Always

Steps to Reproduce:
1. Set up two email accounts with different email address.
2. Send a test mail to each account.
3. Move both of the emails to a Local Folder.
4. Reply to each of them.  
5. Reply to the one from your second account.  The email will by default be sent
from your primary account, when it should be sent from your secondary account.

Actual Results:  
After replying to either of the test emails, the email will be sent from your
primary account.


Expected Results:  
When replying to the email from your secondary account, it should by default use
the email address of the second account as the reply-to.

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 187578 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.