76.com - form doesn't submit

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
15 years ago
3 years ago

People

(Reporter: Ronald Mendoza, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030304 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030304 Phoenix/0.5

A store locator can be found on www.76.com, but filling in the form does not
seem to work.  (Nothing happens when the FIND button is clicked.

Reproducible: Always

Steps to Reproduce:
1. Visit www.76.com.
2. Select the Store Locator from the menu.
3. Enter in a zip code, select a search radius, then click the FIND button.

Actual Results:  
Nothing occurs; the page does not change, and there is no page progress.

Expected Results:  
It should have submitted the information, and a new page should have been returned.

Comment 1

15 years ago
Can confirm this using Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.3b)
Gecko/20030311 Phoenix/0.5 and Mozilla/5.0 (Windows; U; WinNT4.0; en-US;
rv:1.4a) Gecko/20030311, so if at all, this would be a Mozilla bug.

But I get an error message in the JavaScript Console:

Error: setting a property that has only a getter
Source File: http://www.76.com/cjs/mapQuery.cjs
Line: 42

So perhaps there's a problem with the mentioned JS, though page seem to work
with IE 5.5

Comment 2

15 years ago
The problem is with the lines

//return true; 
document.storeformProx.findbtn.x="yes";
document.storeformProx.submit();

Moving to Tech Evangelism.
Assignee: blaker → susiew
Component: General → US General
OS: Windows XP → All
Product: Phoenix → Tech Evangelism
QA Contact: asa → zach
Summary: The Store Locator page on www.76.com does not function. → 76.com - form doesn't submit
please check if this problem still exists, because we want to get rid of
unconfirmed bugs.
Many bugs in here are strill unconfirmed, because eigher nobody sees the problem
or nobody is able to get to the page because of a required login.

(sorry for the spam)
(Reporter)

Comment 4

15 years ago
Still seeing this behavior with 0.6; can confirm error in JavaScript console.
what the heck do they want to set there?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
tech evang june 2003 reorg
Assignee: susiew → english-us
QA Contact: zach → english-us
Problem not found
Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.