Closed Bug 196896 Opened 22 years ago Closed 21 years ago

query shows no components/versions if product name starts with underscore ("_")

Categories

(Bugzilla :: User Interface, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 160557

People

(Reporter: tha, Assigned: myk)

Details

User-Agent:       Mozilla/5.0 (Windows; U; WinNT4.0; de-DE; rv:0.9.4) Gecko/20011128 Netscape6/6.2.1
Build Identifier: Mozilla/5.0 (Windows; U; WinNT4.0; de-DE; rv:0.9.4) Gecko/20011128 Netscape6/6.2.1

We are using Bugzill 2.16
the product/component pages show the components/versions correctly, the query
page shows no component/version, if I select a product name starting with an
underscore.

Reproducible: Always

Steps to Reproduce:
Example from data/versioncache:
$::versions{'_is Pro FDT'} = ['unspecified'];
$::components{'_is Pro FDT'} = ['Demo','Installation','_is Pro CommDTM','_is Pro
DeviceDTM'];

(The example includes components, that have also a leading underscore in the
name. But the problem also occurs with products, that have only 'normal' named
components. )

Verified by renaming one product (in a row of tables ;), after that I could see
the version/component information (including component named "_is Test") in the
query page.
Actual Results:  
The source of the query page contains

cpts[8] = [  ];
vers[8] = [  ];
tms[8]  = [  ];


(where the product "_is Pro Gate" is the 9th entry in the selection.

Expected Results:  
I would have expected these fields contain the respective
component/version/targetmileston list.

May be the problem is in the template form.html.tmpl:

...
[% FOREACH p = product %]
  cpts[[% n %]] = [ 
    [%- FOREACH item = componentsbyproduct.$p %]'[% item FILTER js %]'[% ", "
UNLESS loop.last %] [%- END -%] ];
  vers[[% n %]] = [ 
...
I am unable to reproduce this in 2.17.3.  I can indeed reproduce it in 2.16.2
though.  So this appears to have been fixed already at some point...  the code
involved is a massive chunk of Javascript which has gotten completely re-written
since 2.16.  Trying to isolate the problem and fix it on the 2.16 branch would
be little too high of a risk to justify.
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → FIXED
Target Milestone: --- → Bugzilla 2.18
ok, found the bug that fixed this, so for the record, marking it a dupe
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 160557 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago21 years ago
OS: Linux → All
Hardware: PC → All
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.