using the Casadia (http://www.bitmotion.com/products/cascadia.asp) menus on my webpages leads to a *slow script* warning

VERIFIED DUPLICATE of bug 196911

Status

VERIFIED DUPLICATE of bug 196911
16 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: asa)

Tracking

Trunk
All
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130 Netscape6/6.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130 Netscape6/6.5

Traversing randomly rapidly to & fro across complex cascades of the javascript
menus causes Mozilla to appear to lock up (CPU utils immediately rises to 100%).
After a few minutes Mozilla gets where it should have done earlier and a warning
panel is shown by Mozilla asking for permission to abort a slow script that
might otherwise damage things. 

If the menus are traversed slowly and deliberately or this is done in a less
complex menu system then all is well. Mozilla 1.2.1 and 1.3b do this. 

My site's URL is <http://stburyan.com/index.html>. I've replicated similar
difficulty using Mozilla 1.2.1 in Knoppix Linux-on-CD, so it's not just my
W2kPro-SP2 boxes. The JavaScript menu system known as Cascadia is really giving
Mozilla some grief:-(

Reproducible: Always

Steps to Reproduce:
1. Launching from <http://stburyan.com/index.html> or perhaps
<http://www.stburyan.com/html/commercial.html>
2. hover over the menus to make them fly out, get a whole load opening/closing,
wizz about a bit... that usually does it.
3. Leave some unsaved stuff in an editing package somewhere, that usually
promotes unexpected seizures;~/

Actual Results:  
Mozilla appears to be seized (few several minutes). Further iterations of
Mozilla are not successful. Loading other applications is OK including IE5.5 and
Windows Explorer etc. CPU utils sits at 100% for that few minutes until Mozilla
gets the script done (?) and spawns the *can I abort this slow script that might
cause damage elsewhere* message from Mozilla. 

Expected Results:  
Reached the destination pointed to by the menuing, without further fuss or
sitting at CPU utils 100% etc.

*** This bug has been marked as a duplicate of 196911 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.