problem with FindFirstFile fails in PR_OpenDir clearing cache

RESOLVED INVALID

Status

()

Core
Networking: Cache
P1
critical
RESOLVED INVALID
15 years ago
2 years ago

People

(Reporter: stephend@netscape.com (gone - use stephen.donner@gmail.com instead), Unassigned)

Tracking

({regression})

Trunk
mozilla1.4final
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking1.4b -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Build ID: 2003-03-11-08, Windows XP.

Summary: Crash in [@ nsDiskCacheMap::FindRecord] clearing cache and reloading a
page.

Steps to Reproduce:

Sorry, I can't reveal what URL I crashed on (internal development site), but
here's what I did.

1.  Loaded my URL.
2.  Went in to clear my cache.
3.  Reloaded the URL, crashed.

nsDiskCacheMap::FindRecord
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp, line 412]
0xc3c5123e
nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp, line 951]
nsCacheService::ActivateEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp, line 867]
nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp, line 760]
nsCacheService::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp, line 838]
nsCacheSession::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheSession.cpp, line 83]
nsHttpChannel::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 948]
nsHttpChannel::Connect
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 281]
nsHttpChannel::AsyncOpen
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 2402]
nsDocumentOpenInfo::Open
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp, line 175]
nsURILoader::OpenURIVia
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp, line 606]
nsURILoader::OpenURI
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp, line 567]
nsDocShell::DoChannelLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 5618]
nsDocShell::DoURILoad [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp,
line 5394]
nsDocShell::InternalLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 5182]
nsDocShell::LoadURI [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp,
line 731]
nsDocShell::LoadURI [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp,
line 2452]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 102]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2025]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1293]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 845]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2829]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 861]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2829]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 861]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 936]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3435]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1043]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 183]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1218]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
2219]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3316]
PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6328]
nsButtonBoxFrame::MouseClicked
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp, line 200]
nsButtonBoxFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp, line 147]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6297]
PresShell::HandleEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6232]
nsEventStateManager::CheckForAndDispatchClick
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 2851]
nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1849]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6301]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6215]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2208]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 309]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1944]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1151]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1168]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5431]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5686]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4187]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1435]
USER32.dll + 0x27ad7 (0x77d67ad7)
USER32.dll + 0x2ccd4 (0x77d6ccd4)
USER32.dll + 0x4455 (0x77d44455)
USER32.dll + 0x95d5 (0x77d495d5)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 480]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1285]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1643]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1664]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)

Comment 1

15 years ago
This may be related to bug 197429, for which I've just submitted a proposed
patch.  I still can't reproduce this problem on Windows XP however.
Priority: -- → P1
Target Milestone: --- → mozilla1.4alpha

Comment 2

15 years ago
A few users have crashed with this stack signature.  According to Talkback data,
this crash started with 3/11 Trunk builds:

nsDiskCacheMap::FindRecord   19
BBID range: 17967954 - 18229754
Min/Max Seconds since last crash: 1030 - 142508
Min/Max Runtime: 1424 - 142508
Crash data range: 2003-03-11 to 2003-03-18
Build ID range: 2003031108 to 2003031804

Stack Trace:

         nsDiskCacheMap::FindRecord
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp  line 412]
         nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 951]
         nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 760]
         nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 951]
         nsCacheService::ActivateEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 867]
         nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 760]
         nsCacheService::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 838]
         nsCacheSession::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheSession.cpp  line 83]
         nsHttpChannel::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 948]
         nsHttpChannel::Connect
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 281]
         nsHttpChannel::AsyncOpen
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 2402]
         nsDocumentOpenInfo::Open
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 175]
         nsURILoader::OpenURIVia
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 606]
         nsURILoader::OpenURI
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 567]
         nsDocShell::DoChannelLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5619]
         nsDocShell::DoURILoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5395]
         nsDocShell::InternalLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5183]
         nsDocShell::LoadURI    [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp
 line 726]
         nsDocShell::LoadURI    [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp
 line 2447]
         XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp
line 102]
         XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp  line 2025]
         XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp
line 1293]
         js_Invoke      [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 845]
         js_Interpret   [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2832]
         js_Invoke      [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
         js_Interpret   [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2832]
         js_Invoke      [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
         fun_apply      [c:/builds/seamonkey/mozilla/js/src/jsfun.c  line 1561]
         js_Invoke      [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 845]
         js_Interpret   [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2832]
         js_Invoke      [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
         js_InternalInvoke      [c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 936]
         JS_CallFunctionValue   [c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 3529]
         nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 1066]
         nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp  line 183]
         nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp  line 449]
         nsXBLEventHandler::DoKey
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLEventHandler.h  line 129]
         nsXBLKeyHandler::KeyPress
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLKeyHandler.cpp  line 106]
         nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1663]
         nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3316]
         nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3296]
         nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3296]
         nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1881]
         nsHTMLInputElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/html/content/src/nsHTMLInputElement.cpp
line 1423]
         PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6263]
         PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6214]
         nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2162]
         nsView::HandleEvent    [c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 309]
         nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 1944]
         HandleEvent    [c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 83]
         nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1154]
         nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1171]
         nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 3074]
         nsWindow::OnChar       [c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp
 line 3268]
         nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 3977]
         nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1438]
         USER32.dll + 0x2a2b8 (0x77e2a2b8)
         USER32.dll + 0x45b1 (0x77e045b1)
         USER32.dll + 0xa752 (0x77e0a752)
         nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480]
         main1  [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1284]
         main   [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1642]
         WinMain        [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1663]
         WinMainCRTStartup()

        Source File : c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp
line : 412
     (18061342) Comments: cleared cache  clicked on a link
     (18052683) URL: www.comcast.net
     (18052683) Comments: tried to refresh page and browser crashed
     (18047847) URL: XXX
     (18007655) URL: XXX
     (17977665) URL: XXX
     (17970993) URL: XXX
     (17967954) URL: XXX
     (17967954) Comments: Cleared my cache and then reloaded the page.

This might be related to bug 197429, but there are crashes after that checkin
date so this might be a separate issue.
Keywords: qawanted, regression, topcrash

Comment 3

15 years ago
>Crash data range: 2003-03-11 to 2003-03-18

gordon: so looks like your OSX fix didn't do the trick :(  any ideas?

Comment 4

15 years ago
I believe the Win32 function FindFirstFile() is failing for some reason in
PR_OpenDir() in mozilla/nsprpub/pr/src/md/windows/ntio.c, why I don't know.

I can only reproduce this sporadically, and the failure (seems) to occur
*before* the separate thread is created (we haven't finished moving the
directory yet).

I'll add some code to make ClearDiskCache() more robust, but I wish I knew why
PR_OpenDir() fails.  I've got my breakpoints all set to catch it, but now it
won't fail :-p

Status: NEW → ASSIGNED

Comment 5

15 years ago
Adding M140A to summary since this is a topcrash with Mozilla 1.4 alpha.  Here
is early Talkback data for that release:

 (6)  	 26  	 nsDiskCacheMap::FindRecord
 
  	196917 	ASSI 		gordon@netscape.com 	mozilla1.4alpha 	2003-03-26

   BBID range:            18716271 - 18882885
   Secs since last crash: 2484 (min) - 350508 (max)
   Total Runtime:         2484 (min) - 365227 (max)
   Crash date range:      2003-04-02 to 2003-04-06
   Crash date range:      2003040105 to 2003040105
   Unique Users:          25


   Stack Trace: 
   nsDiskCacheMap::FindRecord
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp  line 412]
   nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 951]
   nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 760]
   nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 951]
   nsCacheService::ActivateEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 867]
   nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 760]
   nsCacheService::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 838]
   nsCacheSession::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheSession.cpp  line 83]
   nsHttpChannel::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 1009]
   nsHttpChannel::Connect
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 296]
   nsHttpChannel::AsyncOpen
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 2500]
   nsDocumentOpenInfo::Open
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 175]
   nsURILoader::OpenURIVia
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 606]
   nsURILoader::OpenURI
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 567]
   nsDocShell::DoChannelLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5632]
   nsDocShell::DoURILoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5408]
   nsDocShell::InternalLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5196]
   nsDocShell::LoadURI	[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp
 line 726]
   nsDocShell::LoadURI	[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp
 line 2447]
   XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp 
line 102]
   XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp  line 2025]
   XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp 
line 1293]
   js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 845]
   js_Interpret	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2832]
   js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
   js_Interpret	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2832]
   js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
   js_InternalInvoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 936]
   JS_CallFunctionValue	[c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 3529]
   nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 1068]
   nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp  line 183]
   nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1192]
   nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
2193]
   nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3337]
   PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6353]
   nsMenuFrame::Execute
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp  line 1721]
   nsMenuFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp  line 463]
   PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6322]
   PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6240]
   nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2223]
   nsView::HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 309]
   nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 1959]
   HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 83]
   nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1154]
   nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1171]
   nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5439]
   ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 5694]
   nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 4190]
   nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1438]
   USER32.dll + 0x27ad7 (0x77d67ad7)
   USER32.dll + 0x2ccd4 (0x77d6ccd4)
   USER32.dll + 0x4455 (0x77d44455)
   USER32.dll + 0x95d5 (0x77d495d5)
   nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp  line 480]
   main1	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1287]
   main	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1645]
   WinMain	[c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp  line 1666]
   WinMainCRTStartup()
   kernel32.dll + 0x214c7 (0x77e814c7)

    Source File: 
c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp line : 412

   (18866407) Comments: in preferences i cleared the cache - out of preferences
- clicked on home (www.orf.at) -> crash  
   (18848987) Comments: Just clicked on a link in a local HTML document that was
going to "http://www.cygnus.com/misc/wp/dec96pub/lib-intro.html#lib.headers" 
Just before  I was deleting a lot of stuff in the MailNews interface.
   (18843247) Comments: trying to download a file.. clicked the link.. down went
the dragon. :-)
   (18838178) Comments: clearing cache & reload page
   (18813868) Comments: 7 tabs open.  With tab to my local machine open (running
Apache on W2k Pro)  I selected the URL and pressed ENTER and Mozilla crashed.
   (18802244)      URL: http://phyton.topnet.pl
   (18754914)      URL: http://popfile.sourceforge.net/
   (18741315) Comments: reading email from an IMAP server
Summary: Crash in [@ nsDiskCacheMap::FindRecord] clearing cache and reloading a page. → Crash in Trunk M140A [@ nsDiskCacheMap::FindRecord] clearing cache and reloading a page.
Keywords: nsbeta1
Flags: blocking1.4?

Comment 6

15 years ago
Just wanted to note that this continues to be a topcrasher on the MozillaTrunk.
 The line numbers have changed slightly, so here is the latest stack from Talkback:

nsDiskCacheMap::FindRecord   16
		 196917 	 ASSI 	  	 gordon@netscape.com 	 mozilla1.4alpha 	 09:44:36 
BBID range: 19344019 - 19574581
Min/Max Seconds since last crash: 1386 - 166020
Min/Max Runtime: 5494 - 248267
Crash data range: 2003-04-20 to 2003-04-28
Build ID range: 2003041908 to 2003042708

Stack Trace: 

	 nsDiskCacheMap::FindRecord
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp  line 412]
	 nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 984]
	 nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 791]
	 nsCacheService::SearchCacheDevices
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 984]
	 nsCacheService::ActivateEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 898]
	 nsCacheService::ProcessRequest
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 791]
	 nsCacheService::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheService.cpp  line 869]
	 nsCacheSession::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/cache/src/nsCacheSession.cpp  line 83]
	 nsHttpChannel::OpenCacheEntry
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 1042]
	 nsHttpChannel::Connect
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 292]
	 nsHttpChannel::AsyncOpen
[c:/builds/seamonkey/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp  line 2558]
	 nsDocumentOpenInfo::Open
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 171]
	 nsURILoader::OpenURI
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp  line 618]
	 nsDocShell::DoChannelLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5652]
	 nsDocShell::DoURILoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5428]
	 nsDocShell::InternalLoad
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 5216]
	 nsDocShell::LoadHistoryEntry
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp  line 6234]
	 nsDocShell::LoadURI	[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp
 line 688]
	 nsSHistory::InitiateLoad
[c:/builds/seamonkey/mozilla/xpfe/components/shistory/src/nsSHistory.cpp  line 822]
	 nsSHistory::LoadEntry
[c:/builds/seamonkey/mozilla/xpfe/components/shistory/src/nsSHistory.cpp  line 659]
	 nsSHistory::Reload
[c:/builds/seamonkey/mozilla/xpfe/components/shistory/src/nsSHistory.cpp  line 561]
	 XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp 
line 102]
	 XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp  line 2025]
	 XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp 
line 1285]
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 845]
	 js_Interpret	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 2836]
	 js_Invoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 861]
	 js_InternalInvoke	[c:/builds/seamonkey/mozilla/js/src/jsinterp.c  line 936]
	 JS_CallFunctionValue	[c:/builds/seamonkey/mozilla/js/src/jsapi.c  line 3529]
	 nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp  line 1082]
	 nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp  line 183]
	 nsXBLPrototypeHandler::ExecuteHandler
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLPrototypeHandler.cpp  line 449]
	 nsXBLWindowHandler::WalkHandlersInternal
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLWindowHandler.cpp  line 314]
	 nsXBLWindowKeyHandler::WalkHandlers
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLWindowKeyHandler.cpp  line 164]
	 nsXBLWindowKeyHandler::KeyPress
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLWindowKeyHandler.cpp  line 180]
	 nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp  line
1637]
	 nsXULDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp  line 1279]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3329]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 3321]
	 nsXULElement::HandleChromeEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp  line 4447]
	 GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp  line 820]
	 nsDocument::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsDocument.cpp  line 3618]
	 nsGenericElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/base/src/nsGenericElement.cpp  line 1955]
	 PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6393]
	 PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp  line 6321]
	 nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2246]
	 nsView::HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 308]
	 nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp  line 2028]
	 HandleEvent	[c:/builds/seamonkey/mozilla/view/src/nsView.cpp  line 82]
	 nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1057]
	 nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 1074]
	 nsWindow::DispatchKeyEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 2912]
	 nsWindow::OnKeyDown
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 3001]
	 nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp  line 3900]
	 0x18a16457
 
 	Source File : c:/builds/seamonkey/mozilla/netwerk/cache/src/nsDiskCacheMap.cpp
line : 412
     (19566918)	Comments: clearing cache
     (19539969)	URL: www.evite.com
     (19539969)	Comments: Would not accept cookies and then crashed
     (19448583)	Comments: reloaded a page  

Comment 7

15 years ago
adt: nsbeta1+/adt1
Keywords: nsbeta1 → nsbeta1+, topembed
Whiteboard: [adt1]
Flags: blocking1.4? → blocking1.4b?
Summary: Crash in Trunk M140A [@ nsDiskCacheMap::FindRecord] clearing cache and reloading a page. → Crash in Trunk M140A [@ nsDiskCacheMap::FindRecord] clearing cache.

Updated

15 years ago
Flags: blocking1.4b?
Flags: blocking1.4b-
Flags: blocking1.4+

Comment 8

15 years ago
Discussed in topembed bug triage.  Plussing.
Keywords: topembed → topembed+

Comment 9

15 years ago
Updating summary with M140B since this is still a topcrasher with Mozilla 1.4
Beta.  Let me know if anyone needs the latest Talkback data.
Summary: Crash in Trunk M140A [@ nsDiskCacheMap::FindRecord] clearing cache. → Crash in Trunk M140B [@ nsDiskCacheMap::FindRecord] clearing cache.

Updated

15 years ago
Target Milestone: mozilla1.4alpha → mozilla1.4final

Comment 10

15 years ago
I'll submit a patch with additional error checking to avoid potential crashes.

Comment 11

15 years ago
gordon, any update on the getting a patch together?
Keywords: qawanted

Comment 12

15 years ago
I'll submit a patch later today.

Comment 13

15 years ago
Created attachment 123927 [details] [diff] [review]
take 1, batten hatches when clearing disk cache fails

This is a first pass at prevent a crash because nsIFile::MoveToNative() fails. 
However, it will render the disk cache inoperable for the remainder of the
session.  I'd like to either understand why MoveToNative() fails or find a way
to keep the disk cache working in spite of the failure.

More tomorrow.
How about a nice, clean diff -u?

Comment 15

15 years ago
Created attachment 123933 [details] [diff] [review]
take 2, diff -u

Doh!  Here ya go.

Comment 16

15 years ago
Comment on attachment 123933 [details] [diff] [review]
take 2, diff -u

sr=darin (all seems like good things to do)
Attachment #123933 - Flags: superreview+

Comment 17

15 years ago
Who can review here? It'd be nice to get this in today if we're gonna branch
tomorrow.

Updated

15 years ago
Attachment #123933 - Flags: review+
Attachment #123933 - Flags: approval1.4?

Comment 18

15 years ago
Comment on attachment 123933 [details] [diff] [review]
take 2, diff -u

a=asa (on behalf of drivers) for checkin to 1.4
Attachment #123933 - Flags: approval1.4? → approval1.4+
C:\moz_src\mozilla\netwerk\cache\src>cvs commit -m "Bug 196917.  Crash in nsDisk
CacheMap::FindRecord clearing cache.  patch by Gordon Sheridan <gordon@netscape.
com> r=dougt@netscape.com, sr=darin@netscape.com, a=asa@mozilla.org" nsCacheServ
ice.cpp nsDiskCacheDevice.cpp
Checking in nsCacheService.cpp;
/cvsroot/mozilla/netwerk/cache/src/nsCacheService.cpp,v  <--  nsCacheService.cpp

new revision: 1.78; previous revision: 1.77
done
Checking in nsDiskCacheDevice.cpp;
/cvsroot/mozilla/netwerk/cache/src/nsDiskCacheDevice.cpp,v  <--  nsDiskCacheDevi
ce.cpp
new revision: 1.87; previous revision: 1.86
done
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
*** Bug 206851 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
Thanks Stephen for checking the patch in last night.  I'd like to leave the bug
open however, because the patch fixes the symptom (the crash) but not the
underlying problem (FindFirstFile fails in PR_OpenDir).  It also leaves the disk
cache inoperable for the remainder of the session.  I'd like to find a more
complete solution.

Asa, how would you like this bug marked so it doesn't show up on your radar?  If
I can find a more complete solution in the next few days, I can renominate it
for consideration.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 22

15 years ago
unsetting blocking 1.4+ since it no longer blocks the release.
Flags: blocking1.4+

Comment 23

15 years ago
patch to prevent crash is checked in. 
can someone who is able to reproduce verify this fix?

remove nsbeta1 and [adt1] keyword to get off buffy list (per sgehani off-line
email conversation :-) )

we'd like to keep this bug open to fix the underlying problem post moz1.4final
Keywords: nsbeta1+
Whiteboard: [adt1]
Cathleen - Oddly enough, someone crashed:

build: 2003-05-23-09
MozillaTrunk
Windows 98 4.10 build 67766446
2003-05-28 03:59:26
nsDiskCacheMap::FindRecord 1ff1586a

But I checked Gordon's patch into the trunk on 5-22, so it should've been in the
5-23 build.  Anyway, there are no more crashes since that 1 isolated 5-23 build
incident, and I'm unable to reproduce this crash as of yet.

Updated

15 years ago
QA Contact: tever → cacheqa

Comment 25

15 years ago
Should we at least mark this bug as fixed again?

TESTING:
on an Win XP system, and unable to reproduce the problem:

Mozilla 1.3b (wanted to get near build date of first report).

Open cache directory in Windows Explorer
Clear cache (visual confirmation in Explorer)
Reload page.

-> No crash observed.

I'll try to play around with this more since crash fix verifications would be
very nice to have.

Comment 26

15 years ago
Ben, this bug is being left open to investigate the underlying cause of the
crash.  The patch simply masks the symptom (the crash) but has side effects (the
disk cache can become disabled for the remainder of the session).  I'm seeking a
more complete fix.  We may need to adjust the target milestone, however.
Gordon, do you think you have a good chance of getting to this in 1.5?
Darin, think you could take this in Gordon's absence?

Comment 29

14 years ago
no longer a crash. updating summary and keywords
Keywords: crash, topcrash, topembed+
Summary: Crash in Trunk M140B [@ nsDiskCacheMap::FindRecord] clearing cache. → problem with FindFirstFile fails in PR_OpenDir clearing cache
Assignee: gordon → nobody
new cache code
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.